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Welcome to the world of TK-850/SG2+UZ. 
You are now sailing into the design environment of the V850ES 
microcontroller for developing wireless networks to Ethernet 
gateway applications. Please follow the tutorial step by step. 
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Preface 
 

 

Targeted Readers Software engineers, who wish to become familliar with the design environment of V850 

microcontrollers to develop and evaluate applications on the TK-850/SG2+UZ evaluation 

boards. Readers are expected to possess the basic knowledge of microcontrollers, C 

language, and Windows™ OS. The sample application introduced here assumes the 

possession of two to four TK-78K0/KF2+UZ evaluation boards. 

 

Objective Readers will learn how to play around the TK-850/SG2+UZ evaluation board with the V850 

design environment.  

 

Construction This manual consists of the following chapters 
 

Chapter 1 Installation 
→ Installation of the sample program and preparation of the TK-78K0/KF2+UZ boards. 
 
Chapter 2 Experiences 
→ Experience how to operate the project manager PM+, compiler, and the integrated 

debugger while preparing the implementation of the sample program. 
 
Chapter 3 How To Use PG-FPL3 
→ How to program Flash EEPROM 
 
Chapter 4 Sample Prgram 
→How to use the sample program "RF Test Program" and “Text Chat program” 
 

Chapter 5 Mode Setting of the Board 
→ Explanation of switch setting. 

 
 
NOTES         The information in this document is subject to change without notice. No part of this document 

may be copied or reproduced in any form or by any means without the prior written consent of  
NEC Electronics Corp. NEC Electronics Corp. assumes no liability for infringement of 
patents or copyrights of third parties by or arising from use of a product described herein. 
NEC Electronics Corp. established proven quality assurance procedures for all products 
manufactured by or on behalf of NEC Electronics Corp. As part of product qualification 
process an intensive release test procedure has been established and executed before the 
products are released for mass production and delivered to our clients. NEC Electronics Corp. 
would like to inform, that the standard quality assurance procedure(s) have not been fully 
applied to this product and its documentation and that neither of TESSERA TECHNOLOGY 
INC. or NEC Electronics Corp. can assure the full and error free function and/or the standard 
quality level. 

 
CAUTION          This equipment should be handled like a CMOS semiconductor device. The user must take all 

precautions to avoid build-up of static electricity while working with this equipment. All test and 
measurement tool including the workbench must be grounded. The user/operator must be 
grounded using the wrist strap. The connectors and/or device pins should not be touched with 
bare hands. 

 
Trademarks        ZigBee is a trademark of Koninklijke Philips Electronics N.V. Windows is a trademark or 

registered trademark of Microsoft in the United States and other countries. NEC Electronics, 
V850ES and 78K0 are trademarks of NEC Electronics Corporation in the United States and/or 
other countries. All other registered trademarks or trademarks are property of their respective 
owners. 
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Chapter1  Installation 
 

 

 

This chapter introduces the development tools and explains the installation of the sample program. The sample 

program for V850ES in TK-850/SG2+UZ board communicates with the sample program for 78K0 in 

TK-78K0/KF2+UZ boards. Installation of the 78K0 sample program to TK-78K0/KF2 boards is also explained. 
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1.1 Development Tools 
 
 
 
 

The following development tools are utilized in the TK-850/SG2+UZ board. 
 
● Device File DF703283 V2.11 

The Device File loads the CPU hardware information into the development tools.  

The sample program in this tutorial was compiled for V850ES/SG2, based on the information in the 

device file. 

 
● Integrated development environment PM + V6.11 

PM stands for Project Manager. It is an integrated development environment platform, working on MS 

Windows. Editor, compiler, and debugger are managed on PM +. 

 
● C compiler CA850 W3.10 (Code size limited version) 

Object code size, compiled by the C compiler CA850 W3.10, bundled in the TK-850/SG2+UZ board, is 

limited to the maximum of 128 KByte. 

 
● Integrated debugger ID850-TK V1.04 

Debugging tasks are performed by the debugger ID850-TK on MS Windows communicationing with the 

monitor program stored in the Embedded Flash EEPROM in the microcontroller via USB-UART 

interface. Once the debugger is initiated, object user code is automatically downloaded onto the on-chip 

Flash EEPROM. 

 
● Flash EEPROM programmer PG-FPL 

The programmer is a piece of software, operating on MS Windows. It programs, erases, and verifies 

object code in the embedded Flash EEPROM in the microcontroller, via USB cable from PC. 
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1.2 Installation of Software Development Tools 
 
 
 

1.2.1.  Explanation of this CD-ROM 
 

The attached CD-ROM contains Development Tools, documents and sample soft ware.  
You can install it using an installer. 
 

 
1.2.2. Installation of the software development tools 

Insert the CD-ROM in the CD-ROM drive. The installer is started automatically. 
If it does not start automatically, start SETUP.EXE from Explorer, etc. 
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<1> Selecting Install… from “NEC Electronics Microcomputer Development Tools Setup” open
s the following dialog box.   
Select the device file and the tool to be installed using the check box.  
By selecting Search…, a device file product can be selected by device name 
“Explain” displays an explanation of the selected device file or tool. 
To change the installation destination, select Browse…. 
  
When all the settings are complete, select Install…. 
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<2> To install each development tool, click OK when the install confirmation screen is displayed.  To 
stop installation, click Cancel.  

 

 
 

<3> To install each development tool, click Yes when the software license agreement screen is d
isplayed.  To stop installation, click No.  
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<4> Enter the product ID. The product ID is shown on the attached documents [README.HTML]. 
 

 
 

 

 
<5> Copying the files is started. 
 

<6> If the setup have completed, a dialog box indicating completion of setup is displayed.  Click the 

[OK] button.  This completes installation of each development tool. 
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 Notes on the installation  
・ Support OS: Windows XP and Windows 2000 (only English version) 
・ Administrator authority is required for this installation.  
・ Do not use 2-byte and /*:<>?|"¥;, characters for installation directory name and also do not select 

installation directory path that contains those characters.  
 
 Limitation  
・ C compiler CA850 W3.10 limit the object size to 128 Kbyte. 

 
 

About ID850 
ID850-TK is software added TK-850 supporting module to ID850QB. 
ID850QB in this product is same tools in [IECUBE for V850] and [MINICUBE]. 
If you already have these products and installed ID850QB, you don’t need to install again. But, 
ID850-TK have possibilities not to run by combination of each version of ID850-TK V1.04 and 
ID850QB V3.20. The information about combination of these software are put on TESSERA 
TECHNOLOGY INC. web site (http://www.tessera.co.jp/eng/index.html) as needed.  (A 
combination of bundling software in this product is no problem.) 

 
ID-850-TK can set following break points. 
  Hardware Break  2 points 
  Software Break  4 points (Internal flash memory) 
 
 
 
 
 

1.2.3. Structure of Installed Files 
 

 

Software Development Tools are installed in "C:/Program Files/NEC Electronics Tools" on default 

setting. 

When you use the tools, please open the tools from [Start menu] -> [Programs]->[NEC Electronics 

Tools]. 
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1.3 Sample Environment 
 

 

 

 
 
This section describes the preparations for the sample programs used in this document. The 
preparations consist of installing the sample programs in the customer’s environment. 
 
The installation method and the installation destination are cescribed below. 
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1.3.1. Installing the sample program 
 
 

Insert the TK-850/SG2+UZ CD-ROM in your PC. The [NEC Electronics Microprocessor 
Development Tools Setup] screen will automatically show up. (if this screen does not show up 
automatically, please start setup.exe from Explorer.) 
Press the  Sample Program  button to start the Internet Explorer, and then click the 
[TK-850/SG2+UZ Sample Program] link.  

 

   

 

 

 
If the [TK-850/SG2+UZ Sample Program] is selected, the following window will show up. 

 

Internet Explorer 
will show up 

Click the [TK-850/SG2+UZ Sample 

Program] link.  

The lower line is the link to download 

this tutorial. 
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Please click the Open button. 

In case of windows 2000, 
you will see the [Security Warning] window. Please click  Run . 

 

 

 
InstallShield wizard for TK-Sample Program starts up  

Please click  Next. 
 

 

 
License agreement screen is displayed. 

Please select "I accept the terms in the license agreement".and click Next. 
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Please click Finish. 

 
The sample programs are installded. 
 
The sample program "TK850.EXE" with self-extract file is also intalled. When you need to use the 
original sample programs, you can extract the file "C:/TK850.EXE”. 
 
When you uninstall the sample program. 
Please use "Add /Remove Programs" in the Control Panel. 
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1.3.2. File Configuration of the sample program 
 
The sample programs ware the following folders. 
 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

C:/ 

 

  TK850 

SAMPLE_SG2+UZ 

 

MACV850 LED control application that is used in Chapter 2 

 

V850_RF_Test The packet error rate and signal strength indication are 

  monitored.  

  This sample program is explained in "4 Sample Program" 

 

TextChat_080729 This sample program uses MAC library. 
The text message is transmitted and it receives it. 

 
  TK78K0 

 

SAMPLE_KF2+UZ 

 

MAC78K0 LED control application for TK-78K0/KF2+UZ 
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1.4 USB Driver 
 

 

 
You need to install “USB Serial Converter” and “USB Serial Port” in your PC.  
 
When TK-850 is used, it is necessary to install “USB Serial Converter” and the “ USB Serial Port” driver in the host 
machine. Please install the driver according to the following procedures with appending CD in the drive. 
 

Attention  Do not use a USB hub for connecting TK-850/SG2+UZ. 
 
 

1.4.1. Installation of the USB driver 
 

 

Install to Windows2000 
 
１．Once the TK-850/SG2+UZ board is inserted to the PC USB terminal, a wizard will be initiated by the MS 

Windows.  
 
 

New hardware wizard （Windows2000） 

 
 
 

Click
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２．The following window is displayed,  please click “search for a suitable driver …..”  
 

Method 1（Windows2000） 

 
 
 

３．Please select the “CD-ROM drives” only. and click NEXT(N)>. 
 

driver file 1（Windows2000） 

 
 
 

Click 

“Search for a………” 

Selection is confirmed.

Click 

It is confirmed that "CD-ROM 

drives" is checked. 



Chapter 2 Experiences  

  

 17

４．Please click  NEXT(N)> 
 

Instillation of the driver file 1 (Windows2000) 

 
 

 
 

５．The “USB Serial Converter" driver's installation is completed. Click  Finish . 
 

Completion of the USB Serial Converter driver installation 1 (Windows2000) 

 
 
 

Click 

Click 
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６．The “USB Serial Port" driver's installation begins continuously. Click NEXT(N)>. 

 

New hardware wizard 2（Windows2000） 

 
 
 
 

７．The following window is displayed. Select “Search for a suitable driver for my device”. and click NEXT(N)>. 
 

method 2（Windows2000） 

 
 
 

Click 

Click 

“Search for a …..” 

 selection is confirmed. 
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８．Please Select the “CD-ROM drives” only. And click NEXT(N)>. 
 

 

Driver file 2（Windows2000） 

 
 
 
 

９．Please Click NEXT(N)>. 

 Instillation of the driver file 2(Windows2000) 

 
 

Click 

It is confirmed that "CD-ROM 

drives" is checked. 

Click 
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１０． The“USB Serial Port”driver’s installation is completed. Click  Finish .  
 

Completion of the USB Serial Port driver installation (Windows2000) 

 
 
 
１１． Driver Install was finished. 
 

 

 

 

 

 

Click 
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Install to Windows XP 
 
１． Once the TK-850/SG2+UZ board is inserted to the PC USB terminal, a wizard will be initiated by the MS 

Windows.  
 

Installation1(WindowsXP) 

 
 
 
 
２． Select the “Install the software automatically …” has been selected, and click NEXT(N)>. 
 

New hardware wizard 1(WindowsXP) 

 
 

 

“Install the software…” Selection is 

confirmed. 

Click 

Click 

Select “No, not this time” 
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３． The “USB Serial Converter" driver's installation is completed. Click  Finish .  
 

Completion of the USB Serial Converter driver installation 1（WindowsXP） 

 
 
 
４． The “USB Serial Port" driver's installation begins continuously. Click NEXT(N)>. 

 

Installation2(WindowsXP) 

 
 
 

Click 

Click 

Select “No, not this time” 
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５． The “USB Serial Port" driver's installation begins continuously. Click NEXT(N)> 
 

New hardware wizard 2(WindowsXP) 

 
 
 
６． If the following window is displayed, the USB driver's installation is completed. Click  Finish. 
 

Completion of the USB Serial Port driver installation (WindowsXP) 

 
 
７． Driver Installation has been finished. 
 

Click 

Click 

“Install the software…” Selection is 

confirmed. 
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1.4.2. Confirmation of the installation  
 
Please confirm “USB Serial Port (COM?)” in the device manager of system in the 
control panel of the MS Windows. Then, please confirm “USB Serial Converter”. 
 
 

Device Manager 

 
 
The screen above shows that the COM port number is "COM3".  
To set the COM port for ID850-TK, use "Portconfig for ID850-TK" and specify COM3 after the 
software is installed. 

When you change the USB port number, the COM port number will be changed as well. 
 
※Attention 
 
Windows2000/XP 

Please do not do “Hardware Modification Scan” when you communicate with the 
target device. 

 

It is confirmed that “USB 

Serial Converter" exists. 

It is confirmed that “USB Serial 

Port (COM?)”exists. 
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1.4.3. Uninstallation of the USB driver  
 

The uninstall program, Ftdiunin.exe, is available at “/DRIVER/FTDI”. Please log on as an 
administrator, then, execute the Ftdiunin.exe  
  

The USB driver’s uninstall 

 
 
 
After TK-850 is detached, please click is Continue . 
 

Driver uninstaller 

 
 

Double click 

Click 
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Please click Finish.  
 

The driver's uninstall completion 

 
 
 
 
 
 
 
 
 

Click 
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Chapter2  Experiences 
 

 

 

 

In this chapter, you will experience how to use the development tools with using the sample 
programs. The development tools are : 
  - Integrated Development Environment, PM+ 
  - Integrated Debugger, ID850-QB 

 
You will be able to understand how to use the development tools and the concept of project files 
which you need for producing application programs.  
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Overview 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Debugging 

Open the workspace for a project 

Check Debugger Settings 

Start-up PM+ 

Check Board Settings 

Compile for an execution file 

Starting integrated debugger (ID850-TK) 

Executing program

Stopping program 

Terminating integrated debugger (ID850-TK)

Terminating PM + 
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2.1 Starting up PM+ 

 
 
 

Now you start to experience development tools. 
To start up PM+, please select [Programs] -> [NEC Electronics Tools] -> [PM+ V6.11] in the 
Windows start menu. 

 
 

 

 

 
 
 
 

PM+ strats up 
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2.2 How PM+ looks like 
 
 

 
In PM+, a project is defined. A project comprises of (an) application program(s) and environment. 
In a project, editing, building, and debugging of source codes are managed by PM+. PM+ also 
defines a work space. A work space comprises of one or more projects, and managed by PM+.   

 
 

 

 
 

 

 
Project Window: A window where the project names, source files, and include files are displayed 

in a tree structure 
Output Window: A window where build execution status is displayed 

 
     For details of the menu bar and the tool bar, please refer to the PM+ User’s Manual. 

Project Window Output Window 

Tool Bar 
Menu Bar 
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What is a project? 

A project is the unit in which PM + executes management, and refers to an application system and 

environment development based on PM +. 

PM + complies project information and saves it in a “project file”, from which it is then referenced. 

 

What is a project file? 

A project file is a file to which information such as the source file to be used in the project, the device name, 

the tool options for complying, and the editor and debugger to be used have been saved as “project 

information”. 

The file name format is “ΔΔΔΔ.prj”. 

Project files are created in folders that are set when creating new workspaces. 

 

What is a project group? 

A project group is a group comprised of a number of projects in an application system. 

The target devices of each project that can be registered to one project group must be the same. 

 

What is a workspace? 

A workspace is the unit used to manage all the projects or project group required for one application 

system. 

The file name of multiple project files is saved to a workspace file for referencing. 

The file name format is “ΔΔΔΔ.prw”. 
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2.3 Open a workspace (projects) 
 

 
 
In this section, you utilize an already existing workspace.  
 

 For creation of a new workspace, please refer to the “2.14 How to create a new PM+ 

workspace”. 
The workspace that you use in this section contains the completed version of the LED 
control application source files and project settings. 
In the menu of the PM+, please select [Files] -> [Workspace], then, choose 
“C:/TK850/SAMPLE_SG2+UZ/MACV850/macv850.prw”. 

 If you have not set your environment, please follow the explanation in the 1.3 Sample 

Environment 
 

 

 

 
If you select the ”macv850.prw” file, please open it by the  OPEN  button. 

Please open the directory you 
installed the sample program 
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The workspace file "macv850.prw" contains one project called "MAC_application". You will use this 
project "MAC_application". 
 
 

The workspace“macv850.prw” 

is loaded 

Project Group 

Workspace: macv850.prw 

Project 



Chapter 2 Experiences  

  

 34

2.4 Check Debugger Settings 
 
 
 
 
The debugger settings have been set by the project file as well. However, because those settings 
are important for debugging, some settings are covered in this section. 
 
Select "Tools" on menu bar, then "Debugger Setting...". 
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Check if "ID850-TK V1.04" is selected on "Debugger". 

 

 

 

 
 
 
 
 
 
 
 
 
 

If you cannot select "ID850-TK V1.04", select "Project" on menu bar, "Project settings" -> 
"Tool version settings" -> "Detail settings" -> then select "ID850-TK V1.04". 
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2.5 Check Board Settings 
 
 

 

Before connecting the PC and the TK-850/SG2+UZ with USB, you should check the setting of 

swiches on the board. 

Set the switches of the TK-850/SG2+UZ as follows.  

 

JP1 1-2 short (USB side) 
Bit1 ON 
Bit2 ON 
Bit3 ON 
Bit4 OFF 
Bit5 OFF 
Bit6 OFF 
Bit7 OFF 

SW1 

Bit8 OFF 
 

 

 
 

 
 

SW1 JP1 
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Next, the COM port number allocated by connecting the TK-850/SG2+UZ board with PC is set by 
"Portconfig for ID850-TK". 
 
Then, please select Portconfig  
at [Programs] ->[NEC Electronics Tools]→[ID850-TK]→[V1.04]→[Portconfig for ID850-TK].  
You will find the following window. 
 
Set the COM port number, which selected by connecting TK-850/SG2+UZ board and PC and which 
confirmed in "1.4.2. Confirmation of the installation", by clicking "Port" on "Portconfig for ID850-TK" 
window. 
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2.6 Compile for an execution file 
 
 
You now create the execution file of the project. This task is called Build. 

Please select the build button  , or from the menu [Build], please select [Build]. 

 

 

 
 

 
 
Build is completed. 
 

Build is executed 
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What is build ? 

Build is a function that creates an execution file, etc., from a source file registered to the project. 

PM+ automatically performs compiling, linking, and other processes. 

On the second and subsequent builds, PM+ automatically detects files that have been updated  

from the previous build process, and complies and assembles only the modified files, thereby saving 

the time required for build.  

 
 

What is rebuild ? 

Build compiles and assembles only the source files that have been modified since the previous 

build, whereas rebuild compiles and assembles all of the source files.  

If you have modified compiler options or other settings, you have to execute rebuild. 
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2.7 Start Debugger 
 
 

 
 
In the PM+ window, please select the debug button  , or please select [Build] -> [Debug] in the menu. 

 

 

 

 

                      

 
Click  OK  

If you do not see the debug button, please select [Tools] -> [Debuggers] in the menu of the PM+, then, 

choose “ID850-TK V6.11 Integrated Debugger”. 

ID850-TK is initiated, and the 

Configuration window will show up 
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Please click  YES   to download the load module file. 

 

 

 

  

 

If the download is completed, C source list 

will be displayed in the debugger window.

You are asked to confirm the 

download of the load module file 

The load module file is now downloaded 

into the on-chip Flash EEPROM of CPU
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If the debugger failed to communicate with the monitor program on chip, the error message F01b1 
will show up. 
 

  
 
 
In this case, please confirm the following items, 
 
1. Power supply to the TK-850/SG2+UZ board 
2. Please make sure the following settings in the SW1. 
 

SW1 - 1 ON 
SW1 - 2 ON 
SW1 - 3 ON 
SW1 - 4 OFF 

 
3. Please make sure the COM port, where you connected the TK-850/SG2+UZ board.  

The COM port number you set up in the utility “Portconfig for ID850-TK” shall be identical with 
the one found at at [Control Panel] -> [System] -> [Hardware] -> [Device Manager] -> [Port] in 
your PC. 
 
”Portconfig for ID850-TK” may be found at [Programs] -> [NEC Electronics Tools] -> [Portconfig 
for ID850-TK]. 

 
If you correct one of the three items, please re-start ID850-TK. 
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If you find the error message Ff603, it means the ID code is wrong. 
 

 
 
If you press OK , you will see the following Configuration window to set the ID code. 

 

 
The default value of the ID code in the sample program is “FFFFFFFFFFFFFFFFFFFFh”. 
This ID code can be changed on the "Device" tab screen from "Compiler Common Options…". 
 
The intension of utilizing the unique ID code is to prevent a third party from debugging and 
modifying your source code.  
When the ID code is forgotten, it is necessary to delete all flash memories with built-in CPU. 
Please delete the flash memory by installing "PG-FPL" from CD of the attachment. 
Please refer to Chapter 3 for the usage of "How to use PG-FPL". 
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2.8 Run Programs 
 
 

 
Integrated DebuggerID850-TK displays the status information in the CPU. It also controls the 
monitor program. 

 
The default opening window of ID850-TK looks like as follows, 
 

<Main Window> 

 

 

 
 

 
For more detail, please refer to the user’s manual of ID850-TK Operation. 

 

 

 
 
 
 
 

Status Bar 

Menu Bar 

Status display area

Tool Bar 
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Run the program

 

2.9 Execute the program 
 
 
You now execute the program in the debugger. 

In the ID850-TK window, please press the re-start button  , or please select [Run]→[Restart] in 

the menu bar. 

       

 

 
 
While the program is being executed, the status bar is red. 
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2.10 Halt the program execution 
 

 
How to halt the program execution. 

Press the halt button  , or please select [Run] -> [Stop] in the menu bar. 

 

 

 

 

After the program is halted, the status bar is not red. 

The program is halted 
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2.11 Terminate the debugger 
 
 
 

To terminate ID850-TK, please select [Files] -> [Exit] in the menu bar. 

 

 

 

 

Please press  Yes  , to store the environment and terminate ID850-TK. 

Please press  No  , to abandon the environment and terminate ID850-TK. 

 

The dialog to confirm termination is displayed
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2.12 Sample Application 
 
 
 
This sample program utilizes TCP/IP and HTTP on the TK-850/SG2+UZ board, and wireless 
communications of IEEE 802.15.4 between one TK-850/SG2+UZ board and up to 4 
TK-78K0/KF2+UZ boards. 

We call the TK-850/SG2+UZ board “Coordinator” and the TK-78K0/KF2+UZ boards “Devices”. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Preparation of TK-78K0/KF2+UZ 
 
Now, you are going to write the sample programs to 78K0/KF2 built-in flash memory with using the 
writing software PG-FPL3, which is bandled to TK-78K0/KF2+UZ. 
 
Set the switches of TK-78K0/KF2+UZ as shown below, then write the file "mac_app.hex" under the 
directory "C:/TK78K0/SAMPLE_KF2+UZ/MAC78K0/apps/Release", which is installed in the section 
"1.3.1. Installing the sample program". 
 

SW1 - 1 ON 
SW1 - 2 ON 
SW1 - 3 OFF 
SW1 - 4 OFF 
SW1 - 5 OFF 
SW5 UART side 

 
Write the same sample programs to the other TK-78K0/KF2+UZ. 
 
When you run the application, you can run it as stand-alone system by setting JP1 to 2-3 pin short 
and using 006P battery connected to CN2. 

PC 

HTTP TK-850/SG2+UZ
（Coordinator） 

TK-78K0/KF2+UZ 
（Device1） 

TK-78K0/KF2+UZ
（Device2） 
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Operation Procedure 
 

(1) In case you intend to execute the sample program without using the debugger, please set the 
mode switch as shown below, and then, please make a hardware reset by the reset push 
switch. 

 
TK-850/SG2+UZ 

SW1 - 1, 2, 3, and 4 OFF 
SW1 – 5, 6, 7, and 8 Not cared 

 
          TK-78K0/KF2+UZ 

SW1 - 1, 2, 3, 4, 5, 6, 
and 7 

OFF 

SW1 - 8 ON 
SW5 UART 

 
(2) Please connect your PC to the TK-850/SG2+UZ board with a LAN cable. 

The LAN cable shall be cross, not straight. 
(3) Please apply the power source to the TK-850/SG2+UZ board, batteries or powered USB. 

Then, 
[1] In your PC, please open [Control Panel] -> [Networks] -> [Property] -> [TCP/IP] -> 

[Property]. Please set the following IP address and the subnet mask. 
・IP address: 192.168.0.x  x can be any value between 1 to 99, or 101 to 25. 

・Sunet mask: 255.255.255.0 
Please close the TCP/IP set up window. 

[2] Please start you web browser, such as MS Internet Explorer. 
[3] Please connect your browser to http://192.168.0.100 
  You can modify the URL later at [8] Configuration -> Network 
[4] Please apply power to the TK-78K0/KF2+UZ boards. 
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(4) You may see the following image in your browser. 

   You can come back to this image, anytime if you select [Display] -> [Network Configuration]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(5) If a Device is connected wirelessly, you can see the red line. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Upto 4 devices can be connected in the sample program. To display the latest status, please click 

 the “Update” button. The pink line indicates it is not connected. 

The coordinator checks a device in every 30 seconds. 

Note 1: If you double click one of the device green box connected with a red line, you will jump to (10). 

Note 1 
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(6) If you select [Display] -> [Date], you can find the time the sample program has. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

   ※ The default time is 2000/01/01 00:00:00. 

 

 

(7) 「You can set your time by selecting [Configuration] -> [Date] 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

※ If you want to set 9 minuts and 30 seconds past 9pm on April 11th in 2005, please input 20050411210930. 
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(8) To setup networks, please select [Configuration] -> [Network]. 

You can modify the network configuration in this window. However it will be adopted only after the new configuration 

is downloaded in the Flash EEPROM. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(9) You can open the Flash programming window by selecting [Configuration] -> [Writing Flash EEPROM] 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

※ Please click Execution to store the current settings. 
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(10) If you click a connected device, you can find the following window 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Operation on the WEB browser: 

Upper half is the coordinator, 

Note 1: If you click the SW3 of the coordinator, LED3 on the physical Device 1 becomes on, and then, off. 

Note 2: If you click the SW2 of the coordinator, LED2 on the physical Device 1 bewcomes on, and then, off. 

Note 3: If you click any LEDs of LED1，LED2，LED3，or LED4, the corresponding LED on the physical board will 

 become on, and off. 

  

 

Lower half of the window indicates a Device: 

Note 4: Status information of the Device, 

   ・Address：This is the Mac address of the Device in IEEE 802.15.4. 

   ・Temperature：Measured on the Device 

   ・SW pressed：Indicates which switch was pressed on the Device. 

   ・Time pressed：Time stamp of the pressed switch. 

Note 5: LEDs, LED2, LED3, or LED4, can be on and off. 

Note 6: If the SW3 of the Device is clicked, LED1 of the coordinator is on and off. 

   The information at the Note 4, SW pressed, and Time stamp, will be updated. 

Note 7: If the SW4 of the Device is clicked, LED2 of the coordinator is on and off. 

   The information at the Note 4, SW pressed, and Time stamp, will be updated. 

 

 

To update to the latest status, please click  the “Store” button. 

Note 3 

Note 4 

Note 5 

Note 6 

Note 1 

Note 2 

Note 7 
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Operation on the board: 

On the TK-850/SG2+UZ board, 

(1) By pressing SW3 on the TK-850/SG2+UZ board, LED3 on the Device1 becomes on and off. 

(2) By pressing SW2 on the TK-850/SG2+UZ board, LED2 on the Device1 becomes on and off. 

 

On a TK-78K0/KF2+UZ board, 

(1) By pressing SW3 on a TK-78K0/KF2+UZ board, LED1 of the coordinator becomes on and off. 

(2) By pressing SW4 on a TK-78K0/KF2+UZ board, LED2 of the coordinator becomes on and off. 

 

Please note an LED manipulated on board is not reflected on the Web browser. 

 

 

(11) If you click a device, not connected with a red line, you will see the following window. 
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2.13 Create hex files 
 
 
 
 

 
In this section, how to create a HEX file, which you need for writing programs to TK board with 
PG-FPL (without debugger), will be explained. 
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Select "Build" on menu bar, then "Select Build Mode". 
The window "Build Mode" is opened. 

 
 

Select "Release Build" for "Build Mode", then click  OK  . 
 
Next, select "Tool" on menu bar, then "Hexa Converter Option". 
The window "Hexa Converter Option" is opened. 
Confirm "Use This" is checked and the file path/name for HEX file is specified on "File" tab. 
The screenshot below shows to create a HEX file with the name of "mac_app.hex" in "Release" 
directory under the project directory. 
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Click rebuild button   on PM+ or select "Build" on menu bar, then "Rebuild" to create the Hex 
file. 
 

 
 
 
 
To write programs to TK board, refer to "Chapter 3 How to use PG-FPL". 
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2.14 How to create a new PM+ workspace 
 
 

 
You now create a new workspace and a project. 
Please follow the step by step approach. 
Please select [Files] -> [New Workspace] in the PM+. 

 

 

 

 

 

 

 

 

 

A new window to create a 

workspace is displayed 

You will see some examples in the 

next pages

Workspace File Name (W):  
-> Specify your favorite name of the new 

workspace. 
.prw is automatically added to indicate a 
file type. 
A project file (.prj) with the identical name 
is automatically created. 

Folder: 
 -> Specify a folder for saving the workspace

file by writing its absolute path. 
    The directory can be selected from a

reference dialog box by selecting the 
Browse… button. 

Project Group Name: 
-> Assign a project group name, if you wish 

to manage multiple projects together. If 
nothing is assigned, the workspace file 
name is used. 

Series Name: 
 -> Specify the series name of the device to

be used from the pull-down menu. 

Device Name: 
 -> Specify the name of the device to be

used. 
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To setup tools, select [Detail Setting…] 

 

 

 

     Select  NEXT(N)>  , 

 

 

 
Click  Yes  button 

 

 
Click  Detail Settings  button 

 

 

For instance, please input the following text,

Workspace file name (W) 
 -> Example 

Folder(F) 

 -> C:/TK850/Example 
    Please find it from the Reference 

Project Group Name (G) 
 -> None 

Series Name (S) 
 -> V850 Series 

Device Name (D) 
 -> uPD70F3281Y 
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  Please select  OK   

 

 

 
 Please select   NEXT(N)>   

 

  
                       Please select NEXT(N)>  . 

Please set the following tools 
with the version 
CA850：W3.10  
ID850-TK：V1.04 

We do not use RTOS. 

Select “Not used”. 
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Please select  
[32 registor mode]  

Select [Copy and Use the Sample file] 

 

 

 

 
 Please Select  NEXT(N)>  . 

                    
 

 
                      Please select NEXT(N)> . 
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Please select [Create and Use 
the Sample file]  

 

 

       Please select NEXT(N)>. 

                   

 

                         
        Please select  NEXT(N)>. 
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Please select ID850-TK V1.04 

 

 

 
      Please select  NEXT(N)>. 

 

 

  

 
Please select    Finish    

  

                   

 

 

Please confirm your configuration 
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Now you have completed the creation of your workspace and project. 

 

You can add source files, whenever you like to add later. 

For more detail, please see the next section, How to add source files. 

Project “Example” was registered 
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Now you set up the security ID. 
Please select [Tools(T)] -> [Common compiler option(N)...]. 

 

 

                      

 

                      

Please select Device tab. 
 

                      

 

Window for compiler 

option shows up 

 

Please select [Device] tab. 

Please input your Security ID. 
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The default security ID is input as an 

example here: 0xffffffffffffffffffff 

                   

  

Please select Apply . 

 

 

 

 

    Please select OK 

 

You have completed the configuration of the security ID.  
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2.15 How to add source files 
 

 

You now learn how to add source files in your project. 

Let’s assume the file, “main.c”, has been registered. You now intend to add two files, “a.c” and “b.c”. 

Right click on your mouse the “Source file” in the project window. You will find “Add Source Files (S)”.  

Please click it. 

 

 

 

 

 

 

 

Please select the two source 

files”a.c” and “b.c”. Then, please 

select  Open (O)  . 

By keep pressing  Ctrl  , you can choose multiple of files at the same time.  
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Please confirm “a,c” and 
“b.c” files in the directory of 
the source file. 
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2.16 Terminate PM+ 
 
 

To terminate PM+, please select [File] -> [Exit PM+]. 
 

 
 
PM+ is terminated. 
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Chapter3  How to use PG-FPL 
 

 
 

You now learn how to write Flash EEPROM on the V850ES/SG2 microcontroller using PG-FPL in 
your PC. 
PG-FPL is also required, in case the security ID does not match. Installation of PG-FPL cannot be 
done from the integrated installer of the TK board, but please execute the following setup.exe from 
explorer.  

 
/FPL/fpl_v150/Setup.exe 
 
For more detail of installation, please refer to the user’s manual of PG-FPL. However, you don’t 
need installation of any hardware and driver, because the hardware is ready on the TK board. 

 
To use PG-FPL, please set the mode switch on the TK-850/SG2+UZ board as follows. Then, 
please connect the board to your PC with a USB cable. 
 

JP1 1-2short (USB side) 
Bit1 ON 
Bit2 OFF 
Bit3 ON 
Bit4 ON 
Bit5 OFF 
Bit6 OFF 
Bit7 OFF 

SW1 

Bit8 OFF 
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Please start PG-FPL by selecting [Programs] -> [NEC Tools32] -> [PG-FPL] in your Windows 
start-up menu. 

 
Window of the PG-FPL 

/  

Please select “Setup”. 
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Please select ”PRM File Read” 

 
 
 
 
You will find the PRM files in the CDROM. 
Please select” /PRM/PRM70F3288_V111/70F3281_CSI0.prm” 
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Please select the COM port number you connected your PC with the TK board. 
All of COM port numbers available on your PC will be displayed. 
Please set ”Speed” 38400, ”Frequency” 5.00, “Multiply rate” 4.00. 
Then, please press OK. 

 
 

 
Next, load the HEX file to PG-FPL. 
Click "Load" to open the file "mac_app.hex", which you created in "2.13 Create hex files". 
When it completes successfully, "Success read HEX file." is displayed. 
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Next, write the programs by clicking "Auto procedure". 
When "Auto procedure" is clicked, it processes the "Erase" and "Program" commands.  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
When it shows "Flash internal Verify OK!", it means the writing completed. 
The programs are successfully written to EEPROM. 
Disconnect the USB cable from TK-850/SG2+UZ board 
 

 



Chapter 3 And More  

 

 75

 
Chapter4  Sample Program 

 

 

 

This chapter introduces the usage of other sample programs. 
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4.1 RF Test Program 

 

 

 

This chapter describes how to run the RF test program using TK-850/SG2+UZ and 
TK-78K0/KF2+UZ. 
The RF test program can monitor the “Packet Error Rate”, “Received Signal Strength Indication”, 
etc. 
The RF test program uses USB interface on TK board for the serial port. If you try to write 
programs with using ID-850TK debugger, the monitor program will be written as well. This causes 
programs not to work appropriately. Therefore, you need to use the flash memory program 
software (PG-FPL) to write programs. 
 
 
4.1.1. Procedure for one to one transmit/receive test 
 
For the RF test, prepare one TK-78K0/KF2+UZ board and write the program 
"TK78K0KF2UZ_RF_Test", which is bundled with TK-78K0/KF2+UZ. 
 
In the same way, prepare one TK-850/SG2+UZ board, write the program 
"C:/TK850/SAMPLE_SG2+UZ/V850_RF_Test/Release/RF_TEST.hex", by using PG-FPL. 
For creating hex object code, refer to "2.13 Create hex files". 
For writing programs to flash memory, refer to "Chapter 3 How to use PG-FPL". 
  
* The RF Test Program uses USB interface on TK board for the serial port. If you try to write 

programs with using ID-850TK debugger, the monitor program will be written as well. This causes 
programs not to work appropriately. Therefore, you need to use the flash memory program 
software to write programs. In the same way, you cannot debug the programs using ID-850TK. 

(Hereinafter, TK-850/SG2+UZ board and TK-78K0/KF2+UZ board are reffered as to the transmitter 
and the receiver, respectively). 
 

 

 

 

 

 

 

 

 

 

 

 

Receiver TK-78K0/KF2+UZ 
Write "TK78K0KF2UZ RF Test" 

Transmitter  TK-850/SG2+UZ 
Write "V850_RF_Test" 

Short address：0001 Short address：0002 
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 Please set the switches on the receiver board(TK-78K0/KF2+UZ) as follows. 

 

JP1 1-2 Short (USB side) 
Bit1 OFF 
Bit2 OFF 
Bit3 OFF 
Bit4 OFF 
Bit5 OFF 
Bit6 ON for address setting
Bit7 OFF for address setting 

SW1 

Bit8 ON for the Receive mode
 

The above example is for the short address of 0002. 

There are four ways of the address setting as follows, 

 

Short Address 
 

0001 0002 0003 0004 

Bit6 OFF ON OFF ON 
SW1 

Bit7 OFF OFF ON ON 

 
By setting SW1-8 to ON, it becomes the receive mode. If you set them to OFF, it becomes 
hyperterminal key input mode (this mode will be explained later in this document)  
Please connect the receiver board (TK-78K0/KF2+UZ) to your first PC with a USB cable. 

 

Now the receiver board(TK-78K0/KF2+UZ) is ready. 

 

Next, you will set the transmitter (TK-850/SG2+UZ) and PC. 
 Please set the transmitter(TK-850/SG2+UZ) board as follows, 

 

JP1 1-2 short(USB side) 
Bit1 ON 
Bit2 OFF 
Bit3 OFF 
Bit4 OFF 
Bit5 OFF 
Bit6 OFF for address setting 
Bit7 OFF for address setting 

SW1 

Bit8 OFF for the transmitter mode 
 

This example is for the short address of 0001. 

This board is designated as the transmitter. 
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Then, please connect it to your PC with a USB cable. 

 

Then, please identify the COM port number of the USB in your PC  

at [Control Panel]  [System]  [Hardware]  [Device Manager]  [Ports (COM&LPT)]  

 

Hyper Terminal 
 

On MS-Windows in your PC, please select [All Programs] -> [Accessory] -> [Communication] -> 

[HyperTerminal] 

 

Setting of Hyperterminal 

  

 

 

 

 

 

 

 (Property -> Setting -> ASCII) 

 Local Echo OFF 

 No Line Feed 

 

Bits per second 19200 

Data bits 8 

Parity None 

Stop bits 1 

Flow control None 
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Reset the transmitter board. 
 Press RESET (SW4) on transmitter board (TK-850/SG2+UZ). 
 
Now you will find the following opening menu in the window. 
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Execution of the Transmit/Receive Test 
 

To initiate the PER, Packet Error Rate, test, please press “1” in the menu. You will see [My Profile], 

then, be asked for the destination of the PER test, as shown below. 

 

 
 

Now, you may input “0002”. 

Then, you will be asked how many packets you wish to consume in the PER test. 

You may input “1000”. 

Then, you will be asked the interval of packets in msec. 

You may input 3 msec. 

Then, the PER test will be executed.  

 

You will see, 

the number of packets sent, that is, 1000 as you input, 

the number of the received packets, 

the calculated PER in % 

and the maximum and minimum RSSI values in the PER test. 

 

[Note]  

PER= Packet Error Rate 

RSSI= Received Signal Strength Indication 
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Command? >1 (PER test/sender) 
 
[My Profile] 
------------------------------------- 
  MAC : 22:95:78:01:00:00:00:47 
Short : 0001 
PanID : 2514 
------------------------------------- 
Send to (Short addr) ? : 02 
Send count (dec)     ? : 1000 
Interval (dec/msec)  ? : 3 
[Set channel to 11 (Cmd)] 
Prepare to send..OK 
[Set channel to 11 (Current)] 
Send..     0 
Request to result..OK 
 
 
[Results] 
------------------------------------- 
From     : 0001 
To       : 0002 
------------------------------------- 
Sent     : 1000 
Recieved : 1000 
PER      :   0.0000% 
RSSI     : max ff / min ff 
------------------------------------- 
 
[Set channel to 11 (Current)] 

 

 

RSSI is expressed in the hexagonal value of 256 levels, which indicates the signal strength in the 

received signal. For more details of the RSSI value, please refer to the datasheet of the UZ2400 

RF chip. 

 

Please note the PER and the RSSI are measured at the receiver side. 

The receiver does not send back the test packets, but only the test result. 
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4.1.2. Channel setting 
 

In the previous example, you may have also found the RF channel used in this test is the Channel 

11. The channel is specified by the IEEE 802.15.4 specification. 

The channel 11 is assigned at 2405 MHz. You can change the channel in the PER test in 5MHz 

step to the maximum channel of 26th at 2480 MHz. 

To do it, please press “9” in the command prompt. Then, please choose the channel by [+], [-], [A], 

[B], or [C]. In the example below, the channel 23th, 2465 MHz, was selected.  
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To execute the PER test at the channel 23, press [Enter] in your keyboard, then, 

choose “1” to initiate the PER test mode. Then, you may input 1000 packet in 5 msec interval to 

see the following example. Please confirm the channel used is 23th in the display. Please note the 

receiver will learn which channel is to be used for the test automatically. 
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4.1.3. Adjusting the output power 
 

You may wish to control the output power in the PER test.  

For it, please select “0” in the menu. 

You will be asked the register ID. Please input “203”. 

Then you will see, “LREG[203] : 00 >”. 

It means the current value at the register [203] is 0x00h, which means 0 dB. 

0x00h is the reset default. 
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The register bits are defined as follows, 

 

LREG[203]:  

[7:6] -> large scale tuning 

 00: 0 dB  

01: -10 dB 

10: -20 dB 

11: -30 dB 

[5:3] -> small scale tuning 

000: 0 dB 

001: -1.25 dB 

010: -2.5 dB 

011: -3.75 dB 

100: -5 dB 

101: -6.25 dB 

110: -7.5 db 

111: -8.75 dB 

[2:0] -> 000 

 

For instance, if you wish -15 dB, please input “60”, as follows, 

 

“LREG[203] : 00 > 60”  

 

Then, you will start the PER test. 
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The minimum output power is set by “F8”. 

 

 

 
 

You may find larger PER value with smaller RSSI value in this case. 

 

 
 

Please note this adjustment is applied only to the transmitter. The receiver always sends back the 

test results with the 0 dB output power using the channel 11th. 
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4.1.4. PER test / receiver 

 

The Menu 2 sets the board to the receiver in the PER test. 

If you have two PCs, you can connect two boards to each of two PCs, then, you will apply this 

mode to one of them.  

In your current case, your receiver board is now being connected to the debugger. Therefore, you 

cannot access to these menu to utilize this mode setting. Alternatively, you have set the receiver 

board to the receiver mode by setting the switch 1-8. 

 

4.1.5. Continuous TX / Pseudo Noise 

 

The Menu 3 initiates the modulated RF transmission. The data carried are pseudo random 

numbers. You can define the channel using the menu 9, and the output power using the menu 0. 

 

 

4.1.6.  Continuous TX / Raw carrier 

 

The Menu 4 initiates the carrier transmission. The output power is not 0 dB as a reset default. You 

can define the channel using the menu 9. 

 

4.1.7. RX Mode 

 

The Menu 5 initiates the receiver mode. 

 

4.1.8. IDLE MODE 

 

The Menu 6 sets the UZ2400 into the IDLE mode. 

 

4.1.9. Sleep MODE 

 

The Menu 7 sets the UZ2400 into the Deep Sleep mode. 

 

 

4.1.10. Standby MODE 

 

The Menu 8 sets the UZ2400 into the Standby mode. 
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4.1.11. Set RF channel 

 

The Menu 9 allows you to set the RF channel. 

 

 

4.1.12. Manually set UZ2400 register 

 

The Menu 0 allows you to set the UZ2400 registers. 

Please refer to the datasheet of the UZ2400 RF chip for the definition of registers. 

 

 

4.1.13. Resetting RF 

 

The Menu A allows you to reset the UZ2400 registers. 
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4.2 RF Test Program 

 

 

 
This chapter introduces the usage of Text Chat Prgram 
 

The Text Chat Prgram is developed to provide with a simple example to construct a 
star network utilizing the IEEE 802.15.4 PHY/MAC standard. 
 
The Text Chat Prgram offers, 

1. Designation of a network coordinator in a star configuration 
2. Text chat between a coordinator and an end device 

 
To use the Chat Program, you need to prepare at least two PC with a USB 
interface or one PC with more than one USB interface, and two TK-850/SG2+UZ 
boards.  
 
The Text Chat Prgram is provided in the form of the C source codes.  
 
If you wish to tailor the sample program to meet your specific needs, you can edit 
the source code, re-compile it with debug build to generate a load module file, then, 
start the debugger to load the tailored execution code on to the microcontroller for 
further debugging on the project manager PM +. In this procedure, the Flash 
programmer is not required. However, because the USB connection to instruct 
operation to the program is occupied for the debugging purpose, alternatively, you 
can make a release build to achieve a new hex file, on the project manager PM +. 
 
As a general remark, please respect your local regulation of electro-magnetic 
emission. In general, it is suggested to use the TK-850/SG2+UZ board in a radio 
anechoic chamber. 
 
It supports text chat for one coordinator and 4 end devices. 
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4.2.1. Programming to the TK boards 
 

For chatting, please prepare minimum 2, or maximum 5 TK-850/SG2+UZ boards. 
You need identical numbers of PCs. 
 
Start PM+, and open the file 
 " C:¥TK850¥SAMPLE_SG2+UZ¥TextChat¥macv850.prw ". 
 
Select "Tools" on menu bar, then "Compiler options". 
 
Select "Preprocessor" tab on "Compiler Options" window. 
 
To write programs on the first TK-850/SG2+UZ, enter " MAC_ADDR=0x0001" on 
"Define Macro". For the second and third TK-850/SG2+UZ, enter 
"MAC_ADDR=0x0002" and " MAC_ADDR=0x0003". The number "x" of " 
MAC_ADDR=x" must be a unique number. 
 
Click re-build button on PM+ or select "Build" -> "Rebuild" on menu bar to rebuild. 
then write different programs to each TK-850/SG2+UZ by using PG-FPL. 
 
For creating hex object code, refer to "2.13 Create hex files". 
For writing programs to flash memory, refer to "Chapter 3 How to use PG-FPL". 
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4.2.2. Setting up the board to your PC 
 
Set the TK-850/SG2+UZ as shown below. 
Connect it to PC with USB cable. 
Confirm the power LED on TK-850/SG2+UZ is lighted.  
 

JP1 1-2short (USB side) 
Bit1 ON  
Bit2 OFF 
Bit3 OFF 
Bit4 OFF 
Bit5 OFF 
Bit6 OFF 
Bit7 OFF 

SW1 

Bit8 OFF 
 
 
Start the Hyper Terminal. 
Settings of the Hyper Terminal should be set as follows. 
 

 
 
 
 
 
 

Press SW4 (RESET SW) once after Hyper Terminal is started. The sample application 
starts after resetting. 
 
In the same way, connect the other TK-850/SG2+UZ board to PC, and start Hyper 
Terminal. If the PC has more than one USB ports, you can connect to more than one 
TK-850/SG2+UZ boards, and you can start more than one Hyper Terminals for those 
COM ports on each board. 
 

 
 

Bits per 
second 

19200 

Data bits 8 
Parity None 

Stop bits 1 
Flow control None 
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4.2.3. Hyper Terminal 
 

Now you will find the following opening menu in the window. 
If not, please try the RESET button on the board. 
 

 
 
Then, press Enter, 
 

 

 
Please do the same for your other boards and PCs. 

----------------------------------------- 

  TK-78K0R+UZ Sample Application 

----------------------------------------- 

  2007 Skyley Networks 

 

  MY MAC extended address 

  =123412349ABC001 

 

  Command > 

[Help] ------------------------- 

S: Send Message 

M: MLME Associate test 

C: Start Coordinator test 

-------------------------------- 

 

Command? > 
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4.2.4. Designation of a coordinator 
 

Now, you must decide which board is a coordinator. 
Go to the PC of the coordinator board, and press C. 
 

 

Now the coordinator has started. 
 

4.2.5. Network Association 
 

For other PCs for other boards, please press M. 
 

 
 
Now, this particular board was associated to the network as an end device with 
the short address of 4321. Please repeat this step for your third, fourth, and 
possibly fifth board. 
 

Command? >M 

 

> MLME-ASSOCIATE.request 

> MLME-ASSOCIATE.confirm 

>  Associated ShortAddr:4321 

>                Status:00 

 

Command? > 

Command? >C 

 

> MLME-START.request 

> MLME-START.confirm 

>  Status:00 

 

Command? > 
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On the coordinator side, you will find the following message, if the association is 
successful. 
 

 
 

 
4.2.6. Text Chat 

 

Now the network is prepared for you to start text chat between an end device and 
the coordinator. 
 
At first, you may start with the coordinator. 
 
Press S, then input the short address of an end device, 4321 in this example, 
then, input your text message, up to 102 bytes.  
 

 

 

 

 

Command? >S 

 

> MCPS-DATA.request 

> Send to (short address) ? 4321 

> Message ? Hello! 

 

Command? > 

> MLME-ASSOCIATE.indication 

>  from 123400019ABC0001 associated to 4321 

 

[Help] ------------------------- 

S: Send Message 

-------------------------------- 

 

Command? > 
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You will find the following message on the end device, 4321. 
The sender’s short address is “1975”, and the PAN ID is 2420 in this example. 
 

 
 
Now, you can reply from the end device “4321” to the coordinator “1975” by 
inputting S, 1975, and your reply text. 
 
 

 

 

 

 

 

 

 

 

 

Command? > 

> MCPS-DATA.indication 

>  from 1975/2420 

Hello! 
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Chapter5  Mode setting of the TK-850/SG2+UZ board 

 
 

The combination table of the switch of this board is shown. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

＊ Set this ON when you use serial communication through USB connection. 
 

Case
Switch Normal mode Debug Mode with 

USB connectionUSB PG-FPL 

SW1 - 1 OFF/ON ＊ ON ON 
SW1 - 2 OFF ON OFF 
SW1 - 3 OFF ON ON 
SW1 - 4 OFF OFF ON 
SW1 - 5 Don’t care Don’t care Don’t care 
SW1 - 6 Don’t care Don’t care Don’t care 
SW1 - 7 Don’t care Don’t care Don’t care 
SW1 - 8 Don’t care Don’t care Don’t care 

SW1 

SW2 SW3

LED1，LED2，LED3，LED4 
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Mode setting of the TK-78K0/KF2+UZ board 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Usage case 
SW 

Normal  (Written 
program works) 

Debug  (USB 
Connection) Writing flash 

SW5 UART side OCD side UART side 

JP1 
Select by power supply

source 
1-2short (USB side) 1-2short(USB side) 

Bit1 OFF ON ON 
Bit2 OFF ON ON 

Bit3 OFF ON OFF 

Bit4 OFF ON OFF 

SW1 

Bit5 OFF ON OFF 

 

 
 

 

SW1 

JP1 

SW5 



Revision History  

  

 98

Revision History 
Revision Updated Pages 

Ver 1.0 April 5, 2007 Initial Version - 
Ver 1.1 June 25, 2008 Manufacturer change - 
Ver 2.0 March 06, 2008 Change with Sample program change - 
   

 

 

 


