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Introduction

Target Readers This document is intended for users who will use for the first time the \850™

series development tools.
A basic knowledge of microcomputers, C language, assembles, and Windows™ operating is

assumed.

Purpose This document is designed to give readers an understanding of the basic operation methods for the
V850 Series development tools provided with the TK-850/JG2 evaluation kit.
Readers will be able to further their understanding by actually using the development tool while reading
this document.

How to Use this Manual  This PDF file should be read with Adobe™ Acrobat™ Reader 5.0 or later.

Organization This manual consists of the following contents.

CHAPTER1 PREPARATIONS

->This chapter provides an outline of the V850 series development tools used in this guide and
describes the sample program installation method.
CHAPTER2 PRACTICALS

->This chapter allows the reader to experience the basic operations of PM + and the monitor-version
integrated debugger using sample programs.
CHAPTERS3 OTHER

->This chapter describes how to create a new PM + workspace (project), how to use the monitor

program, and gives an outline of the sample programs.

Cautions -This contents of this document are subject to change without prior notice.
-No part of this document may be reproduced without the prior written permission of NEC Electronics
Corporation.

-NEC Electronics Corporation does not make any guarantees nor does if grant any license regarding
intellectual property rights or any other right of NEC Electronics Corporation or third parties pertaining to
the use of the products and the use of the information described in this document. NEC Electronics
Corporation shall not be held liable for problems related to the rights of third parties that arise from the
above uses.

-The circuits, software, and appurtenant information described in this document is provided solely for the
sake of semiconductor device operation examples or application examples. Therefore, in case these
circuits, software, and/or information items are to be used for a customer’s equipment, the design of
said equipment shall be the responsibility of the customer. NEC Electronics Corporation declines any
and all responsibility for damages arising from the use of such circuits, software, and/or information by

a customer of a third party.



Trademark Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the
United States and/or other countries.
Adobe and Acrobat are trademarks of Adobe Systems Incorporated (Adobe System Incorporated).
Other company names and product names that appear in this document are the registered trademarks or

trademarks of their respective companies.



CHAPTER1 PREPARATIONS

This chapter provides an outline of the development tools used in this document and describes how to install the sample
programs.
The sample program function only for the development tools listed as included in the TK-850/JG2 evaluation kit in this

document.



CHAPTER 1 PREPARATIONS

Used development tools

This section outlines the development tools used in this document.
The name of the development tools and their main function are as follows.

- Device file DF703724 V1.00

Since the device file contains the device-specific information, this file is required for using the development tools.
The sample used in this document has been created as a V850ES/IG2 program.

- Integrated development environment PM + V6.00
This is an integrated development environment platform that operates on Windows.
An editor with an idea processor function is provided as the Edit window, allowing efficient development linked with
development tools such as a compiler and a debugger.

- C compiler package CA850 W3.00 (Size restriction Version)
This product generates execution code that can be executed in the V850 Series from C source programs and
assembler source programs.

CA850 W3.00 in software development tools are put restrictions on object size (to 128Kbyte).

If you already have release to manufacture (V version), please don't install CA850 in this product.

- Monitor-version integrated debugger ID850-TK V1.01
This is Windows-based software that runs on a host PC.
Itis integrated debugger that achieves debug at source level C.
Source debug of the reference, the change in the variable, and the step execution, etc. by such source line can be
done easily and efficiently.

- Program for writing to on-chip flash memory of microcontroller PG-FPL
This a Window-based software used to write programs to the on-chip flash memory of a microcontroller.
It is possible to write/delete it to a built-in flash memory of TK-850/JG2 by connecting TK-850/JG2 with the PC with
an attached USB cable.

The above-listed development tools must be installed in order to operate the sample programs described in this document. For
the installation method, refer to the “TK-850/JG2 User's Manual Software version "(¥DOC¥TK850¥TK-850JG2_SW_E.pdf).
Also refer to the TK-850/JG2 User's Manual for the restrictions on the development tools.

The documentation assumes that the name of the installation destination folder is “C:¥Program Files¥NEC Electronics Tools”.



CHAPTER 1 PREPARATIONS

Sample environment

This section describes the preparations for the sample programs used in this document. The preparations consist of installing the
sample programs in the customer’s environment.

To uninstall the sample programs, delete the folder that was specified as the installation destination.

The installation method and the installation destination are described below.
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- Installing the sample programs

Insert the CD-ROM disk provided as part of the TK-850/JG2 evaluation kit in the CD-ROM drive. The [NEC Electronics
Microprocessor Development Tools Setup] screen automatically appears. (If this screen does not appear automatically,

start setup. exe from Explorer. etc.)
Press the button to start the WWW browser, and then click the [TK-850 Sample Programs] link.

Fieadme First

The WWW browser
start up.

Install...

Documents

Sample Program
— e — —

Link ta MEC Electronics Micracomputer

Exit

/3 sample Programs - Microsoft Internet Explorer =lol =]
File Edit View Favorites Tools Help ﬁ
$=Eack - = - g 7t | @oearch Garavorites Gvedia <F | B S
Adeiress [ @ F:\DOCISAMPLE_E.HTML = Peo |L|nks »

=

Sample Programs
Click the [TK-850/JG2 Sample Program]

link. you can also downloard the
[Tutorial Guide].

Welcome to TE-850/1G2 weorld.

The purpose of sample programs is to experience TE-850/J(32

Sample programs consist of the following iterns
Copy them to the PC which TE -850/JG2 has mstalled.

« TERI0
o SAMPLE JG2: Sample program described in the TE-850/TG2 evaluation kit tutonial guide

&r to the tutorial guide i each sample program folder for usage.

o TE-B50/TG2 evaluation it tuterial suide
o« TE-B50/T1G2 sample programs

=
@ ([ B

When [TK-850/JG2 Sample Program ] is clicked, the following download confirmation window appears.

Some files can harm your computer. IF the file information below
: looks suspicious. or you do nat fully trust the source, do not open or
zave Hhis file:
! File name:  TKE50.exe
E File type:  Application
Fram: F:ASAMPLE

@ This type of file could harm your computer if it contains
malicious code.

“wiould you like to open the file or save it to pour computer?

Mare Infa |

¥ slways ask before opening)this type of file

Press the button.
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Save it Ia Mew Folder

x| = ® ek E-

File: name:

Save as ppe;

[TKes0

I.&pplicatinn

j < Save I>
ﬂ Cancel |

g

After specifying the download destination folder, press the button. The self-extraction sample program set
(TK850.exe) is copied to the specified folder. When TK850.exe file is executed, the “TK850” folder is created. Also, a folder

containing the various sample programs are created below



- Folder structure of sample programs

CHAPTER 1 PREPARATIONS

When the sample program set is decompressed, the files are organized according to the following folder structure.

4 I
TK850
(— SAMPLE_JG2
’i SAMPLE_JG2.prw Workspace file
—— main.c Source file
(N J




CHAPTERZ2 PRACTICALS

This chapter lets the reader experience the operation of the completed V850ES/JG2 program using the
monitor-version integrated debugger (ID850-TK).

This is a program in which pressing SW2 on the CPU board of the TK-850/JG2 evaluation kit causes 7segLED
to count up, and pressing SW1 causes the counting up interval to become longer and stop.

This chapter is designed to give an understanding of the concrete operation method of the development tools
(PM +, ID850-TK) and the outline of the project files required when creating application programs, through

building of sample programs and operating ID850-TK.

-10 -



The overall flow is as follows.
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Starting PM +

¥

Loading workspace (project)

¥

Creating execution format

¥

Verifying operation

Starting integrated debugger (ID850-TK)

¥

Executing program

¥

Stopping program

¥

Exiting integrated debugger (ID850-TK)

¥

Closing PM +
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Starting PM +

Let's now actually use the development tools.
First, start PM +.

In the Windows Start menu, select [Program] -> [NEC Electronics Tools] -> [PM+ V6.00].

=101 x|
File Edit Find Layer Wew Project Buld Tool “Window Help
| & - Do SR| 0| W Sles+ -gE| 2]
I RS
EE[cows e
Files | bemo | - [EOF] ‘I
----- rrg No*orkspace
kil ' 4
For Help, press F1 [T 1 et [z
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Introduction to PM +

In PM +, application programs and environment setting are handled as a single project, and series of actions
such as program creation using the editor, source management, build, and debugging are managed.

Also, one or more project files are managed together as a workspace.

Menu bar

Tool bar

3% NEC PM plus - No Workspace [DutPut] - | m] ll

File Edit Find Laver View Project BUilr Tool Window Help
» 7/
I IEE / Sles+-l==le]
| Sl & &R
BER=orr o]
Files | Memo | - [ECF] =
' Mo workspace

For Help, press F1 \ \ l_ ’_ I_F ,ﬁlﬁ v
) \

Project window

Output window

Project window: A window in which project names, source files, and include files are displayed using a
tree structure

Output window: A window in which the build execution status is displayed.

I::> For details regarding menu bars and tool bars, refer to the PM + User's Manual.
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Loading workspace (project)

In this chapter, you will use an already created workspace.

[:> The method for creating a new workspace is described in CHAPTER3 OTHER.

The source file name of the 7seg LED count up program and the V850ES/JG2 setting emulated with

ID850-TK are saved to the workspace used in this chapter.

In the PM + menu, select [File] -> [Open Workspace...] and specify “SAMPLE_JG2.prw".

[> If you have not set an environment, refer to “Sample Environment”.

fﬁ:NEE PM plus - No Workspace [OutPut] =] 3
File Edit Find Layer Wiew Project Build Tool Window Help

Mew Chrl+H

1 «»+ ==

Qpen... ChrH+O [ ﬁ | Eatl j' ”§,:| ?

Insett file. . & EX |

Close

Close Warkspace

Save ChrltS
Save As..

Change Source Fls Mame. ..
Save Al Saurce Files

Prink Prewview
Print. .. Chrl+P

Recent File

Recent Workspace

Exit PM plus

-

K1 H s
Open an existing workspace l_ l_ ,ﬁ ,ﬁ ,W v

Open the folder in which

the sample program is

located.

Open Workspace 2] x|
Look in: | ‘3 SAMPLE_JG2 =] & ®m ok e

TESAMPLE 162,

e

Files of type:  ['workspace Filef*,priv) =] Cancel |
Help |
A

Click “SAMPLE_JG2.prw” and then press the button.




Workspace file name: SAMPLE_JG2.prw
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The “SAMPLE_JG2.prw”

workspace file is read.

fa7PM plus - SAMPLE_JGZ2.prw [OutPut] -2 x|
File Edit Find Layer Wiew Project Buld Tool Window Help
|2 -DEE[8R| s =R Hl«»+ -EREe
JlSAMPLE_JGE-SAMPLE_JGE ][ oebug Buid IR N
= ProjectWindo -0l =] - o] x|
Files |Memc-| B T ZI
-1 Pioject(s] €— .
el [~ Project group
ource Files
Cl Include Files |
D Fraoject Felated Files
L[] Other Files
Project
.
1] v 4
Mowing project completed successfully. l_ ’ﬁ ’W ’W

Only one “SAMPLE_JGZ2" project is included in the “SAMPLE_JG2.prw” workspace file.

The operations described below are done in relation to this “SAMPLE_JG2" project.



Creating

Let's create the project’s execution for
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execution format

mat. This action is called build.

Enter press PM +'s Build button ._i. , or select [Build] -> [Build] from the menu.

f'?, PM plus - SAMPLE_JG2.prw [OutPut]
File Edit Find Layer Wiew Project Buid

=18

Tool Window Help

e - D8R4 5 e LR ETEEY
J [SaMPLE_JG2 SAMPLEJGZ =||DebugBuid = *(.5.-. & £ AW B |
= Project! " =B = output =10l

Fies | Memo |

=] F@ SAMPLE_JG2 : 1 Project{s]
-8 SAMPLE_JG2

(3 Source Files

3 Include Files

(3 Project Related Files
(2 Other Files

- [rzor) ﬂ

K] s
Moving project completed successfully. I_ ﬂ,ﬁ W

Build processing is

executed

PM plus - SAMPLE_JGZ.prw [OutPut] - LI
Fle Edt Frd Layer View Project Buld Tool Window Help
|2 - DSR4 65| BRI @|
| [saMPeigz-seMpLeGe =][Debug Buid RN : | |
= ProjectWi o [=[ 3} . =10l x|
Files |Memu| - "C:\Progrem Files\NEC Electronics TDOls\CASSD\IB.DD\bln\caESD.Ej
_ ~ "C:\Program Files\MNEC Electronics ToolshCASS04WS.00Vkin)caS50.e:
E‘" SAMPLE_JG2 : 1 Project(s] - "C:\Program Files\MNEC Electronics Tools)CASS50%W3.00V\bin\cagS50.e:
Bl @ SAMPLE_JG2 - rC:\Program Files\NEC Electronics Tools)CASS0%W3.00Vbin)cagS0.e:
[ Source Files — rC:\Program Files\NEC Electronics Tools)CASS50%W3.00Vbinasgs0.e
(2 Inchude Files — rC:\Program Files\NEC Electronics Tools)CASS50%W3.00Vbin' 1d850.e
- (] Project Related Files - "o ©s Tools|CAS504W3 .00Ybint hx850.e
- (1 Ot Files I plus ]
- Bu warningis) : 0 [EOF]
@ 13500: Build completed normally.
5
] H
[ L1t frie

Build processing has been normally completed.
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The integrated debugger is provided as user application execution environments (debuggers)
in the ID850-TK.

In this document, the integrated debugger (ID850-TK) is started and the operation is checked using this
debugger.
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Starting integrated debugger (ID850-TK)

To use ID850-TK, it is necessary to connect TK-850/JG2's CPU board to the host machine with an

USB cable, and power it on. After checking that the CPU board is powered, start ID850-TK.

Select the Debug button m of PM +, or in the menu, select [Build(B)]—[Debug(D)].

If the debug button is not displayed, in the menu, select [Tool]—[Debugger Setting...] “ID850-TK V1.01
Integrated Debugger (ID850-TK for TK-850)”

i PM plus - SAMPLE_)G2.prw [OutPut] E =18 =]
File Edit Find Layer Wiew Project Buid Tool ‘Window Help
|%-De &R L e @ Sle» s =lum 2]
| [GAMPLE_JG2 -sAMPLEIGZ =][DebugBuid Sk Ak E|RE
= Proj pR=l = Output | =lalx|
Fies | Memo| [ "Ci\Program Files\NEC Electronica Tools)C 5u\m3.nm\bm\caasn.ei
_ - rC:\Program Files\NEC Electronics Tools)CAG50%W3.004bin|cass.e
E‘. SAMPLE_JG2 : 1 Project(s] - "C:\Program Files\NEC Electronics Tools)CASS50%W3.00\bin\cass0.e
=@ SAMPLE_JG2 - "C:\Program Files\NEC Electronics Tools)CAS50%W3.00\binicag50.e
(1 Source Fies - rCi\Program Files\NEC Electronics Tools)CAS50YWS.00Ybintas850.e
(0 Include Fies - rCi\Program Files\NEC Electronics Tools)CAS50YWS.00Ybiny 1d850.e
(-1 Proiect Reelated Files - "C:\Program Files\NEC Electronics ToolshCASS0YW3.00Vhin\hx850.e
“.[(7] Other Files _—
- Build Total error(s) : 0 Total warning(s) : 0O [ECF]
4 » A

T Likike

ID850-TK starts, and “Configration”

screen is displayed
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onfiguratio x|
' ~
Chip Clack i >
“ame; o [FEE <] ‘ e S -
s Cancel
Internal ROM/RAM el —

Intemal HDM:|51 B 'l Keytes || | &l Project...

SUBOSCIHE | e
[ HAM_|40950* ] Bytes l_[L[] About

Help

Programmable /0 Area ID Cod
’]_ Stark Addressl H’ ‘
— Peripheral Breal 1 — Moniter Clack 5 = Hfie [4F

 Break £ Sustem

IDEK:'I OMHz Vl

% Won Break e

sk

I Wior Eisen Rz FIHDRE T RESET T STOR:

= el T DEINT T MODE 0,1.2 ITalgelDEand 'I

r— Memory Mapping
- ) ) ) Add

AcoeesSize O BB 7 18BR O 32BR

Memary Attribute: Mapping Address & Chip Delete |

Target j I = I j

Press the [OK] button.

“Load Module File” download confirm

message is displayed

x

@ w700 Do wou want ko download Load Module File?

Press the button, and “Load Module File” download begins.

Compiled “Load Module File” are

downloaded to the flash memory with
built-in CPU
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g [ 3]

File Edit “ew Option Run Event Browse Jump window Help

0 [ | [ = e || 2 | 0 0| G|RE|oB| Q| 8|8E =f:8%

O x|

CANEWFOL™ 14 TKBEDSAMPLE ~1ha.out
object loading
symbaol: loading...

Cancel

A --- |ooooooo4 | [EREAK 4

When download ends normally, the

program source is displayed.

§5 IDBS0-TK : SAMPLE_1G2.prj o[]S
File Edit View ©Option Run Event Browse Jump ‘Wwindow Help

1w [ [ = i) 2 | B(B|m| BR8] Qlalw
[E Source {main.c)
Search.. | < | LI il atch I Quick... | Hefreshl Cloze I
1] 17poid main{>
e |[» K
= h_initial(); »% 3C3jAUSASEACAY =/
= __EI{>; = CPUEHETIRE] ilET =~
while <1>¢
e g_start = B;
£ g_led_s = 28;
[ g_count = B;
ol PICA = BxB7; /-
= WIMK = 1; [l
L vhile{ g_start == 8 »; /% Sudido
= PICA = Bx47; s
= WIMK = 8;
= P9L.7 = 1;
P vhile{ g_start == 1 >{ % PsegLE
= if ¢ tPB.4 »{
[ g_start = 2;
>

main.c#18 main 00000004 BREAK v
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Normally, if communication with the CPU, the following error messages are output.

5I

& F01b0: Can not communicate with monitor program, Please check the availability of communication part, the setting of CPU board or the type of cable.

e _|

If these errors occur, check the following items.

Verification items:
1. The CPU board is connecting to USB port on host machine correctly?
2. Please confirm the switch on the board is set as follows.

SW3
Bit 1 ON
Bit 2 ON
Bit 3 ON
Bit 4 OFF

3. Is JP1 made 1-2 short and does power indication light LED1 light?
4 . |s the COM port number set by the COM port and "Portconfig for ID850-TK" allocated in TK-850/JG2
corresponding?

JP1

490 0 0 0 olo ® O 0006000 e 0w o ® o @1,CM

Y O R 5 i
I@ o memmanwma&
i TK BEOIJGZ
MADE IﬁA JAPAN o il @
—= ®- o | P1al@) |
m’ i, Ema = P7B
: TP!NHY—&VU |___) IcN S, 3

SW3

After checking the above items, start ID850-TK again.
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When the ID code is wrong, the following messages are displayed.

Also, this message can be displayed at first start up.

In that case, Please input “FFFFFFFFFFFFFFFFFFFF’[20 of F ] in “ID code”.
ID850-TK x|

& Ff&03: Incorreck ID Code,

The following "Configuration" screen is displayed when is pushed and input a correct ID code, please.

5
— Chip = Clock: oK
FOF3718 - Main DSCMHz] \—I

Marme: uPD
- Cancel

— Intermal ROM/RAM Multiply rate Festoms

Internal FH:IM:IEI 2 'l KBytes I j Project...

Su MSEkHE]
Internal Répd: |4|:|E|E|:|x v| Bytes Iﬁ About...
Help

i

— Programmable 140 Area———
[T Start Address

[ AArET

IDEK='| OtHz "I

= Penpheral Break /= Monitor Clozk 7
£ Break £ System

% Non Break % [zer

i ask
= Wil iR T HEE2 T HLERE T BESET T STOR

™ walT I~ DEINT I~ MODE012 |TagetDepend x|

— Memomn bMapping
AccessSize: % BB 16BR ¢ 32Bi ot
tdemony Attribute; td apping Address & Chip Delete |

Target j I - I j

When the ID code is forgotten, it is necessary to delete all flash memories with built-in CPU.
Please delete the flash memory by installing "PG-FPL" from CD of the attachment.

Please refer to Chapter 3 for the usage of "PG-FPL".



CHAPTER 2 PRACTICALS

Introduction of integrated debugger (ID850-TK)

ID850-TK displayed the CPU core’s internal status and controls monitor program execution in the main
window.
The initial screen of ID850-TK is as follows.

; - Menu bar
< Main window > Tool bar

ESIDS50-TK : SAMPLE_JG2.prj
File Edit ‘iew Option Run Ewenl K onise Jump  Window Help

1o | (o | = ool 2 | B | B0|Me]8| QU s|si

[pfain.ci#13 main looooooos | |BREAK > [ v

/ ~

Status bar

Window display area

&5 ID850-TK : SAMPLE_JGZ.prj
File Edit Wew Option Run Event | Browse Jump ‘Window Help

L I I it ' = | o B §

Assemble

Memary

Wakch

Reqisker

/O Register
Local Yariable
Stack Trace
Trace

(Code Coverage
Consols

s
4 RRM

5 RunBreakTime
6 SymInspect

Select [Browse] -> [Other] -> [2 List] in the menu. Then the list of Source file is displayed.
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D850-TK : SAMPLE_JGZ.prj
File Edit VYiew Option Run Ewvent | Browse Jump

Window Help

Memory

‘Wakch

Register

IO Reqister

Local Yariable
interupt.c Stack Trace
main.c Trace

Code Coverage

Console

Others

Select [Browse] -> [Source Text] in the menu. Then the program Source file is displayed.

{§# IDB50-TK : SAMPLE_JGZ.prj —1olx1
File Edt ‘iew Option Run Event Browse Jump Window Help
INNNEEENEC R E e
E Source {main.c) - |E||1|
Search I < | LI W atch I Quick. | Refresh I Close I
0] 1 poid main(d =]
>
19|
i iad 28 h_initial<>; % ACAJAVAAAEACAY =~
L interupte be 21 IO ’ #% CPUzaésiRé] itigT %/
[ mainc o5
23] wvhile <13>{
24
3 25| g_start = B3
e 26| g_led s = 28;
e 27| g_count = B;
28|
e %% PICA = BxB7; #= SU2
iad 31 WIMK = 1;
32|
3 33 while{ g_start == @ >; /% AuAiB0RESCE
i 34 PICA = Bx47; s% SU2
35|
e 36| WIMK = 8;
372
e 38| PL.7 = 13
39|
e 48| while{ g_start == 1 »{ /% 7segLEDé|i6_
e 41| if ¢ tPA.4 3{
e 42| g_start = 2;
43| >
iad 44 >
45 L
i 46 vhile ¢ g_start == 2 > {
i 47| if ¢ g_led_s >= 68 >{ % AJa
[ 48 g_start = B;
i 49 PIL.7 = B; L‘
58 > =
e 51 : 2
S I | | b T
4 | .
|main.c#18 |main |ooooooos | |BREAK v

E:> For details about the various areas, the menu bar and the tool bar, refer to the “ID850-QB Integrated
Debugger Operating Manual”
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Executing program

Next, execute the program
Select the ID850-TK's restart button | , or select [Run(R)]—[Restart(R)]

The LED count up program is executed.

ID850-TK : SAMPLE_JG2.prj i [w] P33}
File& View Option Run Event Browse Jump Window Help

e[ (=[] = | 0 o] [ 8] Qo] || ] P ¥ |90
E Source {main.c) =18 x|
Seach.. || << | >» | Watch || Buick.. | Fefiesh | Close |

17 id in(> -
L1 foid main =]
19

e 20 h_initialdd; /% ACAJAUSASEACAY »/
be 21 E1¢(3; % CPURAEBIRE] TlET */

23 while <1>{

EER]

27| g_count = @;
b 29 PICA = BxB7; /% SU2
e 3 WIMK = 1;

pe 33 wvhile{ g_start == 8 >; #% Fuaia0aeaCe
P 34 PICA = Bx47; % SH2

ol 36 WIMK = 8;
e 38 PIL.7 = 1;

46 while( g_start /% PsegLEDE[G_
if (¢

]
-
3]

43 >
>

46 while ¢ g_start
47 if ¢ g_1

£
'y
1Y

L ERE]

L3
w
[y
e

KI|

|main.c#1a main |ooooooos | |BREAK

Execute the program

{5 ID850-TK : SAMPLE_1GZ.prj 1ol x|

File Edit View Option Run Ewent Browse Jump ‘Window Help

e e o =] 2] BRI B ek =5 B ]S
2 R

Search | << I £ Wi atch I Quick. | F!efrashl Close |
1
1

(3 commone T _17poid mainC>
St > .
(] initislise.c 19 f e A& sAIIAAKLE A
Dlnlerruptc e 28 h_initial<>; Vel aGaJaUaaaeaE}aY’ *®
mano i d 21 __EIC; /% CPUERRETIRE] ilET =~
2 22
23 vhile (1>{

25 g_start
g_led s
27| g_count

Pe 29 PICO = Bx@87; #% GU2

¥
[
=

e 31 WIMK = 1;

13 while{ g_start == @ >; s% AuA1A0AEAGE
34 PICA = Bx47; s% SU2

il 36 WIMK = 8;
ol 38 PIL.7 = 1;

4R while{ g_start == 1 >»{ s% PsegLEDE[6_
if ¢ PB4 >{

L33
S
=

-4 >
42 g_start = 2;
43 >
>

E3
S
1y

I

46 while ¢ g_start
if ¢ g_

EEEX]
Y
=]

8 >{ /% GdE
H

1101,
-
.
.
e

‘**

B

The status bar changes to red during program execution.
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Next, when you pushed SW2 on the CPU board of TK-850/JG2, 7seg LED starting count up.

When you pushed SW1, the count up interval becomes longer and confirm the stop.

SW1
SW2

50 0000 O0Ee 0000000000000 00 ) anew

el )
voo L ZUSECIREH 1
——an e

© 0@l o ele2

O i e
= TH=850/JGZ b 3
BEI=0394 svoo [:—L
—HMADE IN-_JAPAN
) I 1

7SegLED Reset SW

Press SW2 to start counting up of 7segLED.
7segLED countsupto0->1->2-> ...... 9->0.

Press SW1 to stop counting up of 7segLED.

The count-up interval becomes longer and finally stops.

0 The above-described procedure checks that the 7seg LED count up program functions normally.



Stopping program

Stop the program.

Press the ID850-TK’s Stop button , or in the menu, select [Run] -> [Stop].

ID850-TK : SAMPLE_JGZ.prj =]
AEd\t Vigw Option Run Event Browse Jump ‘Window Help
(ple = (]2 ] @la|m] Bl Qlalslel =)o 5@ (el
e .ox Il
_——
aout Seach.. | < | s | wateh || @uick. | Feeh | Clse |
(3 common.c W 17]lboid mainC> =
] citE.s Pe (>
[ initialize.c 19 L. e T
[ intenupt.c [ 28| h_initiald{d; s% ACajaVaaaEacay =/
Pt P 24 __EI; #% CPUREEBIRE] IhET -

] main.c 23
23 while <1>{

e 25 g_start
26 g_led_s
[ 27 g_count

e 29 PICA = % U2

ind 31 UTMK = 1;

i3 33 while( g_start == @ >; /% AuA180&EALE
P 34 PICE = Bx4?7; o= U2

=3 36 UTHMK = 8;
ad 38 PPL.7 = 1;

48 while( g_start == 1 »{ /% 7segLEDé |6 _
41 if ¢ tPB.4 >{

42| g_start = 2;

43 H

>

46 vhile ¢ g_start == 2 » {
47 if ¢ g_led_s >= 68 >{ s QdA
48 g_start = B;

49 PIL.7 = @

3
£
Yy

EEREE]

|**
kn
]
v

Stop the program.

1D850-TK : SAMPLE_JGZ.pr =10l x|

File Edit Yiew ©Option Run Event Browse Jump ‘Window Help

o e |n = o] o] = | B8 0| 517 R8) Q||| =l:o]m] B ¢ W4 |

i loix]
_—_—
B aout Sealch...l << _LI ‘Watch I Quick.. | Fiefreshl Close: |

8 german.c 17leoid maind> =
citE.s e
0 initalise: ¢ i i T
3 intenupt.c pe 28 h_initial(d; s aCaJaUaaaean_! xS

3 21 EICY; % CPUeEéBiRE] itiET =~
main.c 22|
23 while {1>{

[ 25 g_start =
< 26 g_led s =
e 27 g_count =
[ 29 PICA = Bx@7; s SU2
[ 31 UTHMK = 13

/% Avdia0aEace
/% SH2

1
1
@
~

> 33 wvhile{ g_start
PICE = Bx4?;

ad 36 UTMK = 8;
e 38 PIL.? = 135

48 vhile{ g_start == 1 X{ /% PsegLEDE|}5_
if ¢ 'PA.4 >{

42| g_start = 2;

43 o >

46 wvhile { g_start == 2 » {
47 if ¢ g_led_ s >= 68 >{ s aJa
g_start = B3

49| PIL.7 = @;

TEXE K FFK
- £ o
) B =

¥
an
=
W

P | >

|main.c#33 main |ooooceEz | [BREAK [Manual EBraak v )

When the program stops, the status bar changes back to its original color.
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Exiting monitor-version integrated debugger (ID850-TK)

In the ID850-TK menu, select [File] -> [Exit].

% ID850-TK : SAMPLE_JG2.pri =101 x|
File Edit “iew Option Run Event Browse Jump Window Help
Open... cerl+o h P =S 2o
e o | alalil® B-slm 5 1[v]]6]
Dawvinlaad. .. Quick. | F\efreshl Close |
Load Madule. .. > =]
Upload...
Praiect » | initial(o; /% ACAJAVASABACAY =/
Tojec [EIC>; #% CPURASBIRE] itiET =/
Environment 3
hile <1><
}’— g_start = B;
g_led_s = 28;
g_count = B;
LeeipEm B PICD = BxB7; s GU2
2 S HEWFOL- 1 THESNSAMRLE~ i3, 0ut
3 G HEWFOL~1|TKEE0|SAMPLE~L|SAMPLE_KI2,0r] UTHE = 135
4 i Hew Folder TRESMSAMPLE_KIZISAMPLE KI2,0r while¢ g_start == @ ); /% BUAiA05EACE
= 3 PICA = Bx47; #= GU2
35
Pe 36 UTHMK = 8;
37
Pe 38 P?L.7 = 1;
39
40| while{ g_start == 1 >{ % PsegLEDé|io_
41 if ¢ tPA.4 >{
42 g_start = 2;
43 H
[ 44 H
45 ||
[ 46, while ¢ g_start == 2 > {
Pe 47 if ¢ g led s >= 68 >{ s AdJa
B 48 g_start = B3
Pe 49 PIL.7 = B; -l
50| H 2|
b 1 ¥ =
e L1 52 i k¥
K| 3
main.c#33 main |oooooeez | [BREAK [Manual Break v

The Exit confirmation dialog box is

displayed.

IDB50-TK x|
This will end wour Debugger session.
Do yiou wank to save the settings in the project file #

Yes Mo | Cancel |

Press the button. The current environment is saved and then ID850-TK ends.
ID850-TK ends without preserving a present environment if are pushed.



Closing PM +

In the PM + menu, select [File] -> [Exit PM +].
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i PM plus - SAMPLE_1GZ2.prw [OutPut] _|E||1|
File Edit Find Layer Wiew Project Buld Tool Window Help
New coli ke « » + = |
- =
Open,.. Chrl+0 e | Eatl J' | B2 ?
s .. Dohug Buid Sl L A d x| W
Close:
e — 0| x| =0l x|
ew Woarkspace. .. F—
T — "C:%Progrem Files\MNEC Electronics Tools\CAESD\US.DD\bin\caBSD.eg
S aca"‘ | — ||- "C:\Progrem Files\NEC Electronics Tools)CASS0%W3.00%bincasso.e:
— ksp - "C:%Progresm Filesi\MEC Electronices ToolshCASS504W3.00%bhin'cag50.e
et - "C:iyProgram Files\NEC Electronies Tools)CASS504U3.004bin\cass0.e:
Save G5 — "C:h\Program Files\NEC Electronics Tools\CA850%\W3.00\bin\=a=s850.e
S A%, - "C:4Progresm Files\MNEC Electronies ToolshCAS504W3.00%bin' 1d850.e
— "C:WProgram Files\NEC Electronics ToolshCASS04TW3.00%khinh hx850.e
Change Source File Mame, .. _—
Save All source FHes - Build Total erroris) : 0 Total warning(s) 0 [ECF]
Prink Preview
Prink. .. Chrl+P
Recent File
Recel
-
K1l H 4
Exit P+ and prompt to save the files l_ L: 1 [5:1 [¥:9

PM + ends.



CHAPTER 3 OTHER

This chapter describes how to create a new PM + workspace (project) required for debugging using the

monitor-version integrated debugger (ID850-TK), and how to use the PG-FPL.

Creating a new PM + workspace (project)

Reqistering additional source files

How to use PG-FPL

-32 -
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Creating a new PM + workspace (project)

Create a new workspace and project.
With PM +, a project that includes the basic items required for build can easily be created by inputting each of
various items step by step.

In the PM + menu, select [File] -> [New Workspace...].

55 PM plus - No Workspace [OutPut] 3 =181
Fle Edt Find Layer Wiew Project Buld Tool Window Help
Mew ChrkHi ,—;[ “« %+ - = |
. o 28] \ I=l=]ie
Insert = 5 i®ix (@ |
Close
EE— o]

Save Workspace:

Close Workspare

Save. {5
Save As...

Chenge Source File Hame...
Save Al Saures Fes

Print Preview
Print. .. Chrl+P

Recent File

Riecent Workspace

Exit PM+

Kal} H
Create anew warkspace [ LiRifwr

The dialog box for creating

new workspace is displayed.

<Description of items>

New WorkSpace - Step 1,/9 [Workspace Information] x|
Workspace File Name: *Wworkspace Fils Name :
-> Specify the name of the workspace file that | ’”2 ;"T"‘:"T“T‘”f”m“D”
manages the prpject filesf. . ) _ I~ Cieate Blank Workspace . SZIZZ HZ:fTimeDS[#]
.prw is automatically suffixed as the file oldery 4 Statp Flef]

Browse..
type. I M 5, Register Mode(#)

Project Group Mame :

A project file (.prj) of the same name is | £ Link Ditective File[#]
simultaneously created.

7. Setup Source Files

Series Name : Device Mame :
[/350 Seres =] [wPoroFarze || @ oelect bebugeer
Folder: —— 9. Confirmation
-> Specify the folder for saving the workspace Lﬂsml [#] V850 Seiiss Orly [3-6)
file by writing its absolute path.
This item can be selected from a reference
dialog box by pressing the Browse...
button. This will set up the basic infarmation about the warkspace and the project.

Project Group Name:
-> Specify this item if wishing to manage
multiple projects together in function units. ¢ Back Hews | [ Caneel | Help
If nothing is specified, this item is the same
as the workspace file name.

Series Name:
-> Specify the series name of the device to be
used.

Device Name:
-> Specify the name of the device to be used.

The concrete information set here is

described on the following pages.
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New WorkSpace - Step 1,/9 [Workspace Information] il
Input the workspace information settings “Workspaca File Name
as fO”OWS. |test »21. Workspace [nformation
2 Select Toole
. S I e Bl e 3 Select Real-Time OS(H]
Workspace File Name: T Browse.. | 4. Startup Fle{#)
-> test 5 Register Mode(#)

Froject Group Mame :
Il E. Link Directive Fils[#]

7. Setup Source Files

FOlder: Series Name : Device Mame :
[\/350 S eres =] [wPororaria ] | B ekt Debuager
'>C\TK850\teSt 9. Confimation
: Device Install

[H] YB50 Series Oy (3-6)

(Press the button.)

Project Group Name:
-> DOn,t |npUt th'S item. This will zet up the basic infarmation about the warkspace and the project.

Series Name:
-> V850 Series

< Back <I Mext > I > Cancel Help

Device Name:
-> uPD70F3718

k / Press the button.

PMpius x|

& Q2011: CATKEA0 est

Thiz folder cannot be found. Do vou wizh o create ity

Press the button.

New WorkSpace - Step 29 [Select Tools] x|

Tool Set : 1. Workspace Information

ware Package 4.1 0[Edhd Save | Deletel 332 Select Tools

3. Select Real-Time O5[#)

Toal Versions : .
4. Startup File([#]

Teol | ersion 21| 5 Register Mode(#)
STESED w210 E. Link Directive File[#]
LDG V1.0 7. Setup Source Files
IDB506E Unused 8 et D hugges
\DEE0-TK Unused 4. Confirmation

| | [#]"%850 Series Only [3-6]
4| | *

< Dela\lSetling..I)

Pleaze select the Tools from MEC Electronics to be used

< Back I Mexst » I Cancel Help
Press the |Detail Setting..| button.
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Tool Yersion Detail Setting |

| casso | sTkeso | DG | ID8s0GE | IDEEOTK | |
d | JUnuzed [Unuzed 26
q

300 ) (720N |~ ¥

Please select each tool

version as follows.

CA850  :W3.00 ol ol
ID850-TK :V1.01 WA Series Software Package W4.10[English Version) ;I

850 Series Software Package 4.00[E nglizh “ersion]

I4]

( ak I ) Cancel | Help |

Press the @I button.

MNew WorkSpace - Step 2,9 [Select Tools] 1[

Tool Set: 1. Workspace Information

I[Changed]‘v’BSD Series Software Packag-j Save | Delete | »»2. Select Tools

3. Select Real-Time O5[#)

Tool Yersions :

4. Startup File[#]
e [[versian || & Register Modeit]
CAB50 w300
STEAS0 Y210 E. Link Directive File[#]
e V.01 7. Setup Source Files
IDE500E Uruzed
1D850-TE. W1.01 8. Select Debugger

4. Confirmation

[#]W850 Seriez Only [3-6]

Detal Setting...

Please select the Toals from MEC Electronics to be used.

<Bac:k{ i Mext » I , Cancel Help

TSe———

Press the button.

New WorkSpace - Step 3/9 [Select Real-Time 05] : il

Pleaze zelect the Real-Time OS[RTOS].

RTOS 1. Workzpace Infarmation
2. Select Tools

j »>3. Select Real-Time OS[#)
FBTOS Settings... | 4. Startup File(H]
5. Register Mode(#]

E. Link Directive File[#]

7. Setup Source Files

TK-850 does not use RTOS. 8. Select Debugger

4. Confirmation

[#]%/850 Series Only [3-5]

Pleaze select the Real-Time 05 (RTOS) from MEC Electronics to be used.
Only the installed RTOS from MEC Electranics can be selected.

< Back ‘ Mext » p Cancel Help

Press the button.
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New WorkSpace - Step [Startup File] x|

Flease specify the Startup File.

1. Waikspace Infarmation

% Copy and Use the S ample file 2 Select Tooks
T 3. Select Real-Time OS[#)
€ Uss the Evisting fie ﬂl >34, Startup File(#)
" Copy and Use the Existing file 5. Register Mode{#) Select the “Copy and Use the
Copy from : E. Link Directive Fils[#]
Browisz... | 7. Setup Source Files Sample file”.

= Do Mot specify now 8 Sl DethuEE

4. Confimation

) _ [#] %850 Series Ornly [3-6]
The Startup File Mame ta register

CHTRESMesthanE s Filz Name... |

The Startup File includes codes to be executed on Startup or Fleset.

The zample file initiahizes RAM and stack, then call: the "main' function. In caze of using the sample file,
pleaze customize it according az your target.

The specified Startup File is registered to the Praject Related Files.

<Back<| Mext > I > Cancel | Help
Press the button.

New WorkSpace - Step [Register Mode] Ll

Please select the Register Maode.

‘wWorkspace Information
Select Tools

Select Real-Time OS(#]
Startup File[3#]

E. Register Made(#]

Link Directive File[it]

" 22Register Mode

R

b3

.

" 2E-Register Mode

Setup Source Files

E
7
8. Select Debugger
g

Corfimation

Select the “ 32-Register Mode”.

[#) w850 Seriez Only [3-6]

According as the selected CABS0 Register Mode, the sample Startup File will be copied and used.
The Register Mode etz the number of registers internally uzed by the CABE0. Az a result of unused
registers, the registers nat used by the CABS0 can be used far the application pragram(in assembly
language] and the averhead required far saving and restoring registers can be reduced. Though the

¢ Back <I Mest > I > Cancel Help
Press the button.




CHAPTER 3 OTHER

MNew WorkSpace - Step 679 [LinkDirective File] x|

Flease speci

+ ;Q_r_eate and Lize the Sample 1. Wworkspace Infarmation

2. Select Tools
. Select Feal-Time OS[#)

Ty 1
@ |se |ntemal memary anly " Usze External memory

w

4 Startup File[#]
= Use the Ezisting file Biowse... 5. Register Mode($)
™ Capy and Use the Existing file »»E. Link Directive Fils(H]
Cagy frorm : 7. Setup Source Files

oo || o sesapenage Select the “Create and Use the
Do Mot specify now 9. Confirmation L
N . [#)W850 Series Onlp (3-6] Sample file

The Link Directive File Mame ta register :

CATEBE0 st test. dir File Mame... |

The link. directive file describes infarmation about the allocation of program code and data.

In caze of using the sample file, Please customize it according az pour target. |f pou map the external
RO to the internal ROM area in ROM less mode, please select "use internal memony only™.

The specified link directive file iz registered to the Project Related Files.

< Back I Mext > I Cancel Help
Press the button.

New WorkSpace - Step 7/9 [Setup Source Files] il

Pleaze setup Source Files.
1. wiotkepace Information

Wi 2 Select Tools
3. Select Real-Time OS[#]

JCIEEN | R,
Fremove & | 5. Register Mode(#]

E. Link Directive Fils[#]
>37. Setup Source Files

Up | 8. Select Debugger
3. Confirmation
Down |
[#] %850 Series Ornly [3-6]

Source File Hame :

'T'ou can alzo add zource files by specifying the list file or the folder.
'Y'ou don't need to specify all the files here, and pou can setup source files using [Project]->[Project
Settings] later

< Back ( | Next > | ) Canecel Help

Press the button.
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New WorkSpace - Step 8/9 [Select Debugger] il

Pleaze select the Debugger.

1. wiotkepace Information
* Debugg

Select Tools

Select Real-Time OS[#]
Startup File[#]

Feqister Mode(#]

Link Directive File[#]

Setup Source Files

File name :

C:“Program Files\MEC Electranics Tools4DE50-TEAY .01 4bin%id3

Select the “ID850-TK V1.01"

oM s W R

DOption - >»8. Select Debugger

3. Confirmation

[H] YB50 Series Oy (3-6)

''ou can change the selected Debugger uzing [Tool] -» [Select Debugger].

< Back d Next > I, Cancel Help

\/
Press the button.

New WorkSpace - Step 9/9 [Confirmation] 1 il

Create the workspace and the project as follows,

1. wiotkepace Information
wiorkspace File Mame : = 2 Select Tools
test. prw
Folder : 3. Select Real-Time OS[#)
C:ATKBE0est :
Froject Group Name : 4 S AEL
test 5. Register Mode(#]
Reisslio: - N . Link Directive File(#]
Device Name : 7. Setup Source Files
uPD7OF3718
Tool Set Name : 8. Select Debugger
- velséﬁ};a:nged]\u’%ﬂ Series Software Package 4.10[English +53, Corfimation
e {#) V850 Series Orly [3-6)
LDG VA0
1D850-TK.%1.01 _
Fieal-Time 0% :
Mot uzed
Startup File :
CATKEEM esthortE 2
Fegister Mode :
32-Register Mode - o o g
< [ LH Check the project information

setting contents.

< Back € I Finish I ) Cancel Help

Press the button.




i PM plus - test.pre [OutPut]
File Edit Find Layer View Project Build Tool Window Help
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=18l

|2 -DEd @R 4 =0 @

Hl«=»+ -|[==R

J I test - test

|| Debug Buid

| &

A%t A|ENE|

=101

= ProjectWindo w

Files

35 test : 1 Project(s]
- test

i Saurce Files
-7 Include Files
+]- [ Project Related Files
w23 Other Files

- [ECF] ﬂ‘

registered.

The “test” project has been

=101

Make file created successfully,

This completes workspace and project creation.

O O 0

Additional source files can be registered at any time thereafter.

I::> For details, refer to “Reqistering additional source files”.

Next, setup the security ID

In the PM +, [Tool] — [Compiler common Options...] is selected.

ﬁﬂPM plus - test.prw [OutPut]

J%-DD”E|§&|% S
jIDebu
=101 x|

J [test - test

= ProjectWindow
Fies | Memo |

test : 1 Project(s]
=@ test
i -[] Source Files
-[Z] Include Files
-[Z7 Project Related Files
(L] Otther Files

Compiler Options...

Assembler Options...

Linker Cptions. ..

ROM Processor Options. ..

Hexa Converter Options. ..

Static performance analyzer Options. ..
Starkup STKES0

Startup LDG

=& xl;

[¢»+ -[=@

e+ X |8 |

dumpasao.. .

Debugger Settings...

Register Ex-toal. ..
Start up Ex-tao|

File Compare. ..
Device File Installer

PM+ Settings...
Fortk...
Customize. .,

Record the Key Operations
Elay Back

Save the Key Operations, ..
Load the Macra File. .,

Flay Back the Macra File. ..

Register the Macro Files. ..
Flay Back the Register Macro

=101 ]

-

X4

Set compiler common options.

[ I N RN Y
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Compiler Common Options ll

Fie | Statup | Link Directive | ROM | Flas

Intermediate Output Directon:

| Browse... |

Final Dutput Directary:

I Browss... |

Enar File:

| Browse... |

Thiz edit box can be specified a directary which object files, assembler source files,
assemble list files, frequency information files and extenal variable file are output.
Azeembler source files, assemble list files and frequency information files are output
there when directary name o file name is specified by the option

External variable file is autput there when file name with path is specified by the
option.

Compiler Common

Options setting is open.

oK I Cancel | Spply Help

Click the “Device” tab.

Compiler Common Options ll

Fie | Startup | Link Directive | ROM | Flash  Device

[~ 256 Byte Mode

BFC Register: I

EcLnty 10
|DxFFFFFFFFFFFFFFFFFFFF

The actualities of
"FFFFFFFFFFFFFFFFFFFE"(20 of F)

are taken if there is no problem in the
This edit box can be specified a security [0 bg hexadecimal.

‘when it is specified, +4sid option of the linker iz set. Value Of ID in security.

- J

( oK I) Cancel | Apply Help |

Press the @I button.

Security ID settings are complete.



Registering additional source files

The method for registering additional source files to a project is described below.

The following example shows the additional registration of source files “b.c” and “c.c” with source file “a.c” already
registered.

Place the cursor on the source file in the Project window of PM +, and select [Add Source Files...] displayed in the

right-click menu.

L% PM plus - test.prw [ProjectWindow] =
File Edit Find Layer ‘iew Project Buld Tool ‘Window Help

| - DSH|SR| S 2| | Hes+ -[B=El? |

J Itest-test leebug Build j| PR 3 3PS | B |

= ProjectWindow -10] x| =] 9]
Fies | Memo | =l
E|--- test - 1 Project(s)
Eﬁ test
=0
-E Incl.udE Compiler Options. ..
+ (0 Project Assembler Options. ..
‘.7 Other Fr
Add the source File ko the project l_ ,L_ ,X_ ,\"_

Add Source Files - test 2 2=
Look in: |ﬁ test j - £ EE-
ac
B
|:.E
crtE.s
Select source files “b.c” and “c.c” and
then press the button.
File hame: I"b_c" gl < Open I >
Files of type: ISource Files[" ;% 0257 5] j Cancel |
Help |
Add Files from Folder... |
A

Multiple source files can be selected by clicking the desired source files while pressing key.
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S.E'PM plus - test.prw [ProjectWindow] =1
File Edit Find Layer Wiew Project Buld Tool Window Help
ERIEENE LY e » + -=mle |
J Itesl-test leebugEuiId j| & .'.1. :“E*. 'ﬁ' .2.‘. | I?hﬂ m |
= ProjectWindow =] 3] = =10l x|
Fies | hsemo | - [EOF] =
test - 1 Projectis]
= test
el lclude Eile
-] Project Related Files
“-(_7] Other Files
Source files “b.c” and “c.c”
are additionally registered
to the project.
1] H
For Help, press F1 l_l_ ,L_ IX_IV_
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How to use PG-FPL

It explains the method of deleting the flash memory with built-in V850ES/JG2 by using PG-FPL.

When security ID etc. are forgotten and ID850-TK cannot be connected, PG-FPL is used.

PG-FPL cannot be installed from an integrated installer. Please execute and install

¥FPL¥FPL_V122¥Setup.exe
from the Explorer etc. Please refer to "PG-FPL user's manual” for details of the installation method.

However, it is not necessary to install hardware (driver). As for TK-850/JG2, the hardware of PG-FPL is built in.

The switch of TK-850/JG2 is set as follows, and it connects it with the PC.

SW3

Bit 1 ON
Bit 2 OFF
Bit 3 ON
Bit 4 ON

Please select — [Programs] — [NEC Tools32] — [PG-FPL] of the Windows start menu.

The initial screen of PG-FPL

File_ Device Yiew Help
| —

=101 x|

Ready

Device—
Mame :

Firrmn Yersion ;
ExtCode :
Wendor :

Parameter file
MHarme :
Format :
Wersian :
Processar Ver,

Laad file
MHame
Date
Chiksum :
Area:

Connection ta device
Part :
Speed
Range
Freq. :
Fultiply -

o

[ m[

Push the 'Setup) button.
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zl
Standard | Advance I
T -_

Parameter file |

PRM File Read

—Host connection

Part I - I
Speed I - I

Supy

Frequency I MHz
Multiply rate I

ply oscillatar

— Operation Mode

" Chip Startl vl
" Black Endl 'l
 Area [~ Show Addres

[ Target Reset Message

0K

Cancel

Push the TPRM File Read] button.

2l
Lock i | (<3l PRM70F3724_/100 | & & e E-
=] 70F3715_CS10.prm D =] 70F3721_CSI0.prm 8] 70F3
] FOF3715_CSI3.prm  [&] 70 —CSTTprm (s8] 7OF3721_CSI3.prm || 7OF3
] 70F3716_CSI0.prm [ 70F3719_CSI0.prm  |#8] 70F3722_CSI0.prm
] FOF3716_CSI3.prm  [#] 7OF3719_CSI3.prm |38 70F3722_CSI3.prm
] FOF3717_CSI0.prm [ #] 7OF3720_CSI0.prm  [8] 70F3723_CSI0.prm
] 70F3717_CSI3.prm [ 70F3720_CSI3.prm  |#] 70F3723_CSI3.prm
| | i
File name: I?DF3?1 g Csi0 Open
Files of tyne: | FRM Files[ PRM) | Cancel |

A

¥PRM¥PRM70F3724_V100¥70F3718_CSI0.prm of attachment CD is selected.

ﬂ

Standard | Advance |

Parameter file |?DF3?1 8_C5I0.prm

PRt Filz Read
— Host conpest Supply oscillator
Pot oMz - Frequency |5.00 MHz

%I 33400 vI Multiply rate |4_DD /
e
— Operation Mode

e

' Chip Start IUUU vl
" Block End|U13 'l
) firea I~ | Show &ddres

[T Taget Reset Mezsage

( (] D Cancel |

"Port" selects the COM port number where TK-850 is allocated.

2 Only the COM port number that the personal computer has is displayed in this pull-
down menu.
Please select as follows.
'Speed] 38400,

Push the .

[Frequencyl 5.00. [Multiply rate] 4.00



CHAPTER 3 OTHER

ol x|

2

»» FlaghOpenning.... - Device
Flash Open OK B Hame :

»» ParameterFile Reading....
Success Read ParameterFile. Firmn Version :
s> COMMAND: Device Setup ExtCode -
PRt File Bead OF. “endar -

—— Parameter fila—
Marne : TOF3718_C5I0
Farmat : 0411
Wersion @ W1.00
Processor Ver, 0200

Load file -
Mame
Diate :
Chiksum :
Area

Connection to device -
Paort:  COM3
Speed 38400
Fahge Chip
Freg.: 5.00
Multiply - 4.00

i o

Ready [ hom [

"Erase" The deletion of the flash memory begins when the button is pushed.

_Ioix

File Device Wiew Help

Yk 7 8 ¥

sCOMMAND: Erase :I Device
ecking.. Mame : D7 OF3

F

lazh Erazing...
chip eraze finish.

Firm ersion: 1.04
ExtCode : 7F40h

Wendor 10h
—— Parameter fila
Mame : VOF3718_CSIo
Farmat : 0411
Wersion : W1.00
Proceszar Ver. 0200
Load file -
Mamne
Date :
Chiksum :
Area
Connection to device -
Part:  COM3
Speed 22400
Rahge Chip
Freq.: 500

bultiply - 4.00

L Hal

Ready [ [

If "chip erase finish" is displayed, the deletion of the flash memory is completed.

Please end PG-FPL.

It returns based on the set switch and completion.

SW3

Bit 1 ON
Bit 2 ON
Bit 3 ON
Bit 4 OFF




