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Introduction

Target Readers This document is intended for users who will use for the first time the \850™

series development tools.
A basic knowledge of microcomputers, C language, assembles, and Windows™ operating is

assumed.

Purpose This document is designed to give readers an understanding of the basic operation methods for the
V850 Series development tools provided with the TK-850/KJ2 evaluation kit.
Readers will be able to further their understanding by actually using the development tool while reading
this document.

How to Use this Manual  This PDF file should be read with Adobe™ Acrobat™ Reader 5.0 or later.

Organization This manual consists of the following contents.

CHAPTER1 PREPARATIONS

->This chapter provides an outline of the V850 series development tools used in this guide and
describes the sample program installation method.
CHAPTER2 PRACTICALS

->This chapter allows the reader to experience the basic operations of PM + and the monitor-version
integrated debugger using sample programs.
CHAPTERS3 OTHER

->This chapter describes how to create a new PM + workspace (project), how to use the monitor

program, and gives an outline of the sample programs.

Cautions -This contents of this document are subject to change without prior notice.
-No part of this document may be reproduced without the prior written permission of NEC Electronics
Corporation.

-NEC Electronics Corporation does not make any guarantees nor does if grant any license regarding
intellectual property rights or any other right of NEC Electronics Corporation or third parties pertaining to
the use of the products and the use of the information described in this document. NEC Electronics
Corporation shall not be held liable for problems related to the rights of third parties that arise from the
above uses.

-The circuits, software, and appurtenant information described in this document is provided solely for the
sake of semiconductor device operation examples or application examples. Therefore, in case these
circuits, software, and/or information items are to be used for a customer’s equipment, the design of
said equipment shall be the responsibility of the customer. NEC Electronics Corporation declines any
and all responsibility for damages arising from the use of such circuits, software, and/or information by

a customer of a third party.



Trademark Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the
United States and/or other countries.
Adobe and Acrobat are trademarks of Adobe Systems Incorporated (Adobe System Incorporated).
Other company names and product names that appear in this document are the registered trademarks or

trademarks of their respective companies.



CHAPTER1 PREPARATIONS

This chapter provides an outline of the development tools used in this document and describes how to install the sample
programs.
The sample program function only for the development tools listed as included in the TK-850/KJ2 evaluation kit in this

document.
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Used development tools

This section outlines the development tools used in this document.
The name of the development tools and their main function are as follows.

- Device file DF703734 V1.00

Since the device file contains the device-specific information, this file is required for using the development tools.
The sample used in this document has been created as a V850ES/KJ2 program.

- Integrated development environment PM + V6.00
This is an integrated development environment platform that operates on Windows.
An editor with an idea processor function is provided as the Edit window, allowing efficient development linked with
development tools such as a compiler and a debugger.

- C compiler package CA850 W3.00 (Size restriction Version)
This product generates execution code that can be executed in the V850 Series from C source programs and
assembler source programs.

CA850 W3.00 in software development tools are put restrictions on object size (to 128Kbyte).

If you already have release to manufacture (V version), please don't install CA850 in this product.

- Monitor-version integrated debugger ID850-TK V1.01
This is Windows-based software that runs on a host PC.
Itis integrated debugger that achieves debug at source level C.
Source debug of the reference, the change in the variable, and the step execution, etc. by such source line can be
done easily and efficiently.

- Program for writing to on-chip flash memory of microcontroller PG-FPL
This a Window-based software used to write programs to the on-chip flash memory of a microcontroller.
It is possible to write/delete it to a built-in flash memory of TK-850/KJ2 by connecting TK-850/KJ2 with the PC with an
attached USB cable.

The above-listed development tools must be installed in order to operate the sample programs described in this document. For
the installation method, refer to the “TK-850/KJ2 User's Manual Software version "(¥DOC¥TK850¥TK-850KJ2_SW_E.pdf).
Also refer to the TK-850/KJ2 User's Manual for the restrictions on the development tools.

The documentation assumes that the name of the installation destination folder is “C:¥Program Files¥NEC Electronics Tools”.
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Sample environment

This section describes the preparations for the sample programs used in this document. The preparations consist of installing the
sample programs in the customer’s environment.

To uninstall the sample programs, delete the folder that was specified as the installation destination.

The installation method and the installation destination are described below.
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- Installing the sample programs

Insert the CD-ROM disk provided as part of the TK-850/KJ2 evaluation kit in the CD-ROM drive. The [NEC Electronics

Microprocessor Development Tools Setup] screen automatically appears. (If this screen does not appear automatically,

start setup. exe from Explorer. etc.)
Press the button to start the WWW browser, and then click the [TK-850 Sample Programs] link.

2 NEC Electronics Microcomputer Develop

Feadme First

Documents
[ sewePogon

| Sample Program
[ ——

The WWW browser
start up.

Link to MEC Electronics Micracomputer

E it

#} sample Programs - Microsoft Internet Explorer (=
Fil= Edit Yiew Favorites Tools Help ﬁ
§=Back - = - i) | Qhsearch [lFavorites GfMedia ¢4 | - S

Address @] D:\DOCYSAMPLE_E.HTML | @ |Links =

-]

Sample Programs
Click the [TK-850/KJ2 Sample Program)]

link. you can also downloard the
[Tutorial Guide].

Welcome to TE-B850ET2 world.

The purpose of sample programs is to experience TEK-850/K.J2.

Sample programs consist of the following ttems.
Copy them to the PC which TE-850/EJ2 has installed.

« TER50
o SAMPLE EIZ2 Sample program described in the TE-850/K T2 evaluation kit tutorial guide

&r to the tutorial guide in each sample program folder for usage.

o TE-B50/ET2 evaluation kit tutorial guide
o TE-BSO/ETZ sample programs

|
] [T &y computer

When [TK-850/KJ2 Sample Program ] is clicked, the following download confirmation window appears.

File Download |

Some files can harm your computer. |F the file infarmation below
laoks suspicious, or you do nat fully truzst the source, do not apen ar
save this fils.

File name:  TKE50.exe
File type:  Application
From: D:ASAMPLE

& This type of file could harmn your computer if it contains
malicious code.

Wiauld you like ta open the file ar sawve it ta pour computer?

Open m Cancel | Mare Infa

¥ flwauz ask before opering this wpe of fle

Press the button.

_7_
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- e Bk E-

[:I Documents and Settings
CINECTOOLSS2

| 1Program Files

I TkFEKD

)W IMIT

[:I WlTemp

File: name: ITKSED j < Save I:>
ﬂ Cancel |

Save ag lppe: I.&pplicatinn
F

After specifying the download destination folder, press the button. The self-extraction sample program set
(TK850.exe) is copied to the specified folder. When TK850.exe file is executed, the “TK850” folder is created. Also, a folder

containing the various sample programs are created below
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- Folder structure of sample programs

When the sample program set is decompressed, the files are organized according to the following folder structure.

~
TK850
(— SAMPLE_KJ2
’i SAMPLE_KJ2.prw Workspace file
—— main.c Source file
J




CHAPTERZ2 PRACTICALS

This chapter lets the reader experience the operation of the completed V850ES/KJ2 program using the
monitor-version integrated debugger (ID850-TK).

This is a program in which pressing SW2 on the CPU board of the TK-850/KJ2 evaluation kit causes 7segLED
to count up, and pressing SW1 causes the counting up interval to become longer and stop.

This chapter is designed to give an understanding of the concrete operation method of the development tools
(PM +, ID850-TK) and the outline of the project files required when creating application programs, through

building of sample programs and operating ID850-TK.

-10 -



The overall flow is as follows.

CHAPTER 2 PRACTICALS

Starting PM plus

¥

Loading workspace (project)

¥

Creating execution format

¥

Verifying operation

Starting integrated debugger (ID850-TK)

¥

Executing program

¥

Stopping program

¥

Exiting integrated debugger (ID850-TK)

¥

Closing PM plus
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Starting PM plus

Let's now actually use the development tools.
First, start PM +.

In the Windows Start menu, select [Program] -> [NEC Electronics Tools] -> [PM+ V6.00].

PM plus starts up.

151 x{
File Edit Find Layer Wew Project Buld Tool “Window Help
| & - Do SR| 0| W Sles+ -gE| 2]
I RS
RERj[eows e
Files | bemo | - [EOF] ‘I
----- rrg No*orkspace
kil ' 4
For Help, press F1 [T 1 et [z
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Introduction to PM plus

In PM +, application programs and environment setting are handled as a single project, and series of actions
such as program creation using the editor, source management, build, and debugging are managed.

Also, one or more project files are managed together as a workspace.

Menu bar
Tool bar
fENEE PM plus - No Workspace [OutPut] ;Iglll
File Edit Find Layer Yiew Project Bui® Tool Window Help
» 7/

I IEE / Sles+-l==le]
| Sl & &R
NER=ore R

Files | Memo | - [ECF] =

' Mo workspace

For Help, press F1 \ \ l_ ’_ I_F ,ﬁlﬁ v
) \

Project window

Output window

Project window: A window in which project names, source files, and include files are displayed using a
tree structure

Output window: A window in which the build execution status is displayed.

I::> For details regarding menu bars and tool bars, refer to the PM + User's Manual.
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Loading workspace (project)

In this chapter, you will use an already created workspace.

[:> The method for creating a new workspace is described in CHAPTER3 OTHER.

The source file name of the 7seg LED count up program and the V850ES/KJ2 setting emulated with

ID850-TK are saved to the workspace used in this chapter.

In the PM + menu, select [File] -> [Open Workspace...] and specify “SAMPLE_KJ2.prw”.

[> If you have not set an environment, refer to “Sample Environment”.

fﬁ:NEE PM plus - No Workspace [OutPut] =] 3
File Edit Find Layer Wiew Project Build Tool Window Help

Mew Chrl+H

1 «»+ ==

Qpen... ChrH+O [ ﬁ | Eatl j' ”§,:| ?

Insett file. . & EX |

Close

Close Warkspace

Save ChrltS
Save As..

Change Source Fls Mame. ..
Save Al Saurce Files

Prink Prewview
Print. .. Chrl+P

Recent File

Recent Workspace

Exit PM plus

-

K1 H s
Open an existing workspace l_ l_ ,ﬁ ,ﬁ ,W v

Open the folder in which

the sample program is

located.

Open Workspace ﬂil
Loak in: Ia SAMPLE_KJ2 j = £ B3~

File name:  [SAMPLE_KI2 C Open | D
Files of type: IkaspaceFiIe[".prw] | Cancel |

Help

e
Click “SAMPLE_KJ2.prw” and then press the button.
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The “SAMPLE_KJ2.prw”

workspace file is read.

Workspace file name: SAMPLE_KJ2.prw

/

#ar PM plus - SAMPLE_KJZ.prw [ProjectWindow] -2 x|
File Edit Find Layer ‘iew Project Build Tool ‘Window Help
| & -D@H|&ZE| 5 51| W e+ —|[2E 2
J | SEMPLE_K.J2 - SMPLE_K.I2 ~||pebua Buid
= ProjectWindow ] 5 - o] x|
Files | Memo | - [ECF] —
- .1 Project(s) 4+—ow Proi
- SAMPLE_KJ2 roject group
ource Files
[:I Inchude Files \~
D Project Related Files
L] Other Files
Project
.
1] M 4
For Help, press F1 I_ IL_IX_IY_

Only one “SAMPLE_KJ2" project is included in the “SAMPLE_KJ2.prw” workspace file.

The operations described below are done in relation to this “SAMPLE_KJ2” project.
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Creating execution format

Let’s create the project’s execution format. This action is called build.

Enter press PM +'s Build button z

, or select [Build] -> [Build] from the menu.

PM plus - SAMPLE_K12.prw [ProjectWindow] - 5[

File Edt Find Layer Yiew Project Build Tool ‘Window Help

% -Dd SE| 40| %5 T« + -[2zl2 ]

| [SaMPLE K12 5aMPLE_ KUz =][Debug Buid = &(.-7- )-5: L X WE ‘

i i
Files |M5m| - [EOF] j
= FFQ SAMPLE_KJ2 : 1 Project(s)

=] . SAMPLE_KJ2
(22 Source Files
(21 Include Fies
(21 Project Related Files
*[Z0 Other Files
=
Kl oz
For Help, press F1 [ ol b

Build processing is

executed

™ plus - SAMPLE_K32.prw [OutPut]

File Edt Find Layer ¥iew Projsct Buld Tool Window

IIE-TES|

% D H| SR 5 B

Hle»+-[2=]%

| [SAMPLEKIZ-SAMPLEKJZ =] |Debuig Build Tk Rt R HE ‘

ol

=10ix]

(23 Project Related Files
(21 Other Files

"y

C CETE—
¥

Electronics ToolshCAS504T3.

Files |Memo| - "C:N\Program Files\NEC
- ™Zi\Program Files\NEC Electronics Tools\CAS504%W3.
=) r@ SAMPLE_KJ2 -1 Project{s) || wc:y\Program Files\NEC Electronics Tools'CAS504Ta.
= SAMPLE_KJ2 - ™Zi\Program Files\NEC Electronics Tools\CAS504%W3.
(0 Source Files - ™Zi\Program Files\NEC Electronics Tools\CAS504%W3.
(0 Inchude Files - ™Zi\Program Files\NEC Electronics Tools\CAS504%W3.

5I Tools% CABS04T3.

DD\bin\caESD.exej
004bintcads0.exe
00Ybintcads0.exe’
00Ybintcads0.exe’
004bintas850.exe’
00%Vbink 1d850.exe’
00Vbinihx850.exe’

Buil arningis) : 0 [ECQF]
@ 13500 Build completed normally.

KUl a7
[ I T

Build processing has been normally completed.
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The integrated debugger is provided as user application execution environments (debuggers)
in the ID850-TK.

In this document, the integrated debugger (ID850-TK) is started and the operation is checked using this
debugger.
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Starting integrated debugger (ID850-TK)

To use ID850-TK, it is necessary to connect TK-850/KJ2’'s CPU board to the host machine with an

USB cable, and power it on. After checking that the CPU board is powered, start ID850-TK.

Select the Debug button m of PM +, or in the menu, select [Build(B)]—[Debug(D)].

If the debug button is not displayed, in the menu, select [Tool]—[Debugger Setting...] “ID850-TK V1.01
Integrated Debugger (ID850-TK for TK-850)”

i PM plus - SAMPLE_KJ2.prw [OutPut] - ﬂ
Fils Edit Find Layer Wiew Project Buld Tosl ‘Window Help

| DS W[ SR &0 R @ e+ JsR2]
| [seMPLE K2 - SeMPLEKUZ =] [Debug BuiM - A
Fies | Memo | [ "CiVProgrem Files\NEC Electronics Tm—_,ls\cmso\Iuls.uo\bm\caasu.axaaA
_ | "C:\Program Files\NEC Electronics ToolshCAS50%W3.00)bin)caB50.exe
El. SAMPLE_KJ2 : 1 Projeetls) || »c:\progrem Files\NEC Electronics ToolshCS504W3.00Ykin)cass0.exe’
=18 SAMPLE_KJ2 - *C:\Program Files\NEC Electronica ToolshCASS0YWS.00Vbhin)ca850.exe’
(11 Source Files - *C:\Program Files\NEC Electronica ToolshCASS0YWS.00Vbhin)as8Ss0.exe’
(20 Include Files - *C:\Program Files\NEC Electronica ToolshCASS0YWS.00Vbhiny 1d850.exe’
(21 Project Relaled Files - *C:\Program Files\NEC Electronics ToolshCASS0YWS.00Vbhiny hx850.exe’
(1 Other Fies .
- puild Total erroris) : 0 Total warning(sl : D [EOF]
-
K] oz
Far Help, press F1 Ii Lil [l [¥i9

ID850-TK starts, and “Configration”

screen is displayed
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onfiguratio x|
' ~
Chip Clack i >
“ame; o [T < ‘ e S -
s Cancel
Internal ROM/RAM el —

Intemal HDM:|255‘ 'l Keytes || | &l Project...

SUBOSCIHE | e
[ HAM_|15384* ] Bytes l_[L[] About

Help

Programmable /0 Area ID Cod
’]_ Stark Addressl H’ ‘
— Peripheral Breal 1 — Moniter Clack 5 = Hfie [4F

 Break £ Sustem

IDEK:'I OMHz Vl

% Won Break e

sk

I Wior Eisen Rz FIHDRE T RESET T STOR:

= el T DEINT T MODE 0,1.2 ITalgelDEand 'I

r— Memory Mapping
- ) ) ) Add

AcoeesSize O BB 7 18BR O 32BR

Memary Attribute: Mapping Address & Chip Delete |

Target j I = I j

Press the [OK] button.

“Load Module File” download confirm

message is displayed

x

@ w700 Do wou want ko download Load Module File?

Press the button, and “Load Module File” download begins.

Compiled “Load Module File” are

downloaded to the flash memory with
built-in CPU
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-1l

Fle Edit WYiew oOption Run Event Browse Jump  Window Help

o | o | = i) o | BB 0| 75| Q&R =48

oad

CiMew FoldedTKEENSAMPLE _KJ2\a.out
object: loading...
symbol: loading

Cancal

=== - [ooooooos | [EREAK i

When download ends normally, the

program source is displayed.

§5 IDBS0-TK : SAMPLE_K12.prj o[]S
File Edit View ©Option Run Event Browse Jump ‘Wwindow Help

1w [ [ = i) 2 | B(B|m| BR8] Qlalw
[E Source {main.c)
Search.. | < | LI Yl atch I Quick... | Hefreshl Cloze I
1] 17poid main{>
e |[» K
P h_initial(); % ACAJEUAAGESACAY =/
= s = CPUEHETIRE] ilET =~
while <1>¢
[ g_start = B;
e g_led_s = 28;
[ g_count = B;
= PICA = Bx@7; g
= WIMK = 1; [l
L vhile{ g_start == B »; /% Auaido
= PICA = Bx47; s
= WIMK = 8;
= PeL.7 = 1;
P vhile{ g_start == 1 >{ % PsegLE
= if ¢ tPB.4 <
e g_start = 2;
>

main.c#18 main 00000004 BREAK v
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Normally, if communication with the CPU, the following error messages are output.

ID850-TK x|
& F01b0: Can not communicate with monitor program, Please check the availability of communication part, the setting of CPU board or the type of cable.
==

If these errors occur, check the following items.

Verification items:
1. The CPU board is connecting to USB port on host machine correctly?
2. Please confirm the switch on the board is set as follows.

SW3
Bit 1 ON
Bit 2 ON
Bit 3 ON
Bit 4 OFF

3. Is JP1 made 1-2 short and does power indication light LED1 light?
4 . |s the COM port number set by the COM port and "Portconfig for ID850-TK" allocated in TK-850/KJ2
corresponding?

JP1

Ilﬁii"_

SW3
LED1

After checking the above items, start ID850-TK again.
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When the ID code is wrong, the following messages are displayed.

Also, this message can be displayed at first start up.

In that case, Please input “FFFFFFFFFFFFFFFFFFFF’[20 of F ] in “ID code”.
ID850-TK x|

& Ff&03: Incorreck ID Code,

The following "Configuration" screen is displayed when is pushed and input a correct ID code, please.

Configuration

— Chip - Clock

Name: upD [T0F373¢ -] || MainOSCiiz)

- Cancel
— Intemal ROM/RaMM Multiply rate Fleshore

Irnternal FEIZIM:I25|3x "| K.Buytes I j Froject...

Sub HSCIkHE]
Internal Féyd: |1E384” vl Eytes Iﬂ About....
Help

I:Ia

i

— Programmable 140 &rea

V.
I_ Start Address I Q Ixxxxxxxxxxxxxxxxxxx:1
— Fenpheral Break /= Monitar Elock 7 = HASE T
" Break = Spstem

IDEK=‘| OkHz vI

% Nlon Break % [zer

— ask
™ Wl iR T HEZ2 T HLERE T BESET T STOR

I wlT I DBINT I MODE 01,2 |Target Deperd 7]

— kemon b apping
. . . . Add
Aocess Size: f 8Bt " 1EBit " 2Rt
bd ernory Attribute: td apping Addrezs & Chip Delete |

T arget j I - I j

When the ID code is forgotten, it is necessary to delete all flash memories with built-in CPU.
Please delete the flash memory by installing "PG-FPL" from CD of the attachment.

Please refer to Chapter 3 for the usage of "PG-FPL".
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Introduction of integrated debugger (ID850-TK)

ID850-TK displayed the CPU core’s internal status and controls monitor program execution in the main
window.
The initial screen of ID850-TK is as follows.

; - Menu bar
< Main window > Tool bar

#5 IDB50-TK : SAMPLE_KJ2.prj
File Edit ‘iew Option Run Ewvenb - Jump  Window  Help

1o [ e [ | = || 2 | B(E|m| BR/=E| Qla|dE

fhain.c#l8 main |oooogoos | |EREAK - [ v

/

Window display area Status bar

5 IDB50-TK : SAMPLE_KJ2.prj
File Edit View Option Run Event | Browse Jump Window Help

o[ [ [ ]| § s

Memory

Watch
Reqister

TjO Register
Local Yariable
Stack Trace
Trace

Code Coverage
Console

5 RunBreakTime
& JymInspect

Select [Browse] -> [Other] -> [2 List] in the menu. Then the list of Source file is displayed.
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DB50-TK : SAMPLE_KJ2.prj
ile Edit Wiew Option Run  Event | B

Window  Help

interupt.c:
main.c

Mernory
Watch
Register

I} Register
Local Yariable
Stack Trace
Tirace
Code Coverage
Console

Cthers

Select [Browse] -> [Source Text] in the menu. Then the program Source file is displayed.

i 1D850-TK : SAMPLE_KJ2.prj

File Edit ‘iew ©Option Run Ewvent Browse Jump Window Help

lll»lrl* [=[n]m]2| BlEm B QlawE =

;IEI_I

[E Source {main.c)

Sealch I

LI Wwatch I Quick. I Hefrashl Cloze |

] o s =

3
=

main.c

EEES

¥ ¥ EF

EEER]

r**

>

1'? boid main(d
4

h_initial();
21 __EI{>;

vhile <1>{

% ACAJAVASAHACAY x/
#» CPURAEDIRE] TheT =~

g_start
g_led_s
g_count
PICA = 8xB87;

WIMK = 1;

o
SNS

6
= SUZi

vhile{ g_start == 8 >;
PICB = Bx47;

WIMK = 8;
PeL.7 = 1;

#% AuAIA0REALE
= 5U2:

vhile( g_start == 1 >{

41 if ( 1PB.4 3{
g_start = 2;

43 >

44 >

/% PsegLEDé| _i

vhile ¢ g_start == 2 > {
if ¢ g_led_s >= GBB){
@

g_start
P6L.7 =

[+l '

|main.c#18 i

|ooooooos | |BREAK

E:> For details about the various areas, the menu bar and the tool bar, refer to the “ID850-QB Integrated

Debugger Operating Manual”
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Executing program

Next, execute the program
Select the ID850-TK's restart button | , or select [Run(R)]—[Restart(R)]

The LED count up program is executed.

=] 3]
kI
i [m] P33}
(1 common.c 1] 14|[r= SIH :PB4-/INTP1,URSWZ:PE3/INTPE =/ -]
(JciEs 15
[ initialise.c 16 R R
2 interupt.c 1?/poid maind)
(L] main.c il 19 K
e 28 h_initial{>; #% SCAjAUARAEACAY =~
il 35 __EIC; #% CPURREDIRE] ilET =/
23 while <1>{
24
25 g_start = 8;
e 26 g_led_s = 28;
27 o_count = B;
28
ud g: PICB = Bx@87; % SU2
e 31 UTHK = 13
32
e 33 vhile{ g_start == 8 »; s% AvAl305EACE
i gg PICB = Bx47; s U2
e 36 UTHMK = 83
37
ad 38 P6L.7 = 15
39
48| while( g_start #% PsegLEDé |5 _i
e 41 i i
il 42
43 H
il 44 >
45
pe 46 vhile ( g_start ==
foe 47 if C g_led_s s BJA T
ind 48 g_stal |
il ‘rlz . P6L.7 =
— 1] 1|
main.c#18 main |ooooooos | BREAK | A

Execute the program

1D850-TK : SAMPLE_KJZ.prj _(al x|
File Edit View Option Run Event Browse Jump ‘Window Help
oo |2 |= [oi]oi]2 | BlElm] BIFA Qlalmle] 2l-]m] B v [s]
o JRT=E]
(3 common.c [ ] 13 * BW1:PA4/INTF1.iiPSUZ :FA3/INTPA =/ =]
] intalise.c ig LS
i pvoid main
Dmtgrluptc be [ k
19
s 20 h_initial(d; /% GACAJAUSAGEACAY =~
ol %é __EIC); % CPURHET IRE] LlET =~
23 while <1>{
24
25 g_start = B;
3 26 g_led_s = 28;
27 g_count = B;
28 |
= gg PICA = Bx@7; o= SUZ
pe 31 WTMK = 13
32
d 33 vhile{ g_start == b H #% AvAiS08EACE
e 34 PICA = Bx47; o2 U2
35
e 36 UTHMK = 8;
37
e 38 P6L.7 = 13
39
e 40| vhile{ g_start == 1 »¢{ #% PsegLEDE | i
il 41 if ¢ tPA.4 ¢
L3 42 g_start = 23
43 H
e 44 >
45
e 46 vhile ¢ g_start == 2 > {
ind 47| if ( g_led_s >= 68 >{ o= Ada x|
o 48 g_start a; g
e 49 P6L.7 = =
I | - =

The status bar changes to red during program execution.
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Next, when you pushed SW2 on the CPU board of TK-850/KJ2, 7seg LED starting count up.

When you pushed SW1, the count up interval becomes longer and confirm the stop.

SW1
SW2

TK—!EOIKJZ ot l_ﬂb
BEI=D41K~~ =

L o(_;oQo g

PO OROE 0@ OOOIBIOIOI

7SegLED Reset SW

Press SW?2 to start counting up of 7segLED.
7segLED countsupto0->1->2-> ...... 9->0.

Press SW1 to stop counting up of 7segLED.

The count-up interval becomes longer and finally stops.

0 The above-described procedure checks that the 7seg LED count up program functions normally.



Stopping program

Stop the program.

Press the ID850-TK’s Stop button , or in the menu, select [Run] -> [Stop].

ID&50-TK : SAMPLE_KJ2.prj = Dlﬂ
AEdit Vigw Option Run Event Browse Jump ‘Window Help
o[z il = | BlElm) BIFA Qlalnl@] 2|46 @t
—nix iz
_
) soach. | « | > | Waich | Guick, | Reech | Ciso |
(1 common.c | 14|[-= SU1:PB4/INTP1.UESU2Z:PA3/INTPE =~ =]
[ cnE.s
[ initialize.c 16/ i
23 intemupt.c N 17 Euld main()
main.c 19
P 28 h_initial(>; /% ACAJAVASAEACAY »~
I 21 _EI1O; % CPUEAEDIRE] iliey =~
22
23 vhile <1>¢{
24
25 g_start
pe 26 g_led_s
27 g_count
28 |
ad 29 PICA = s SU2
38
[ 31 WIMK = 1;
32
i3 a3 while( g_start == @ )3 s% GuAiA0REACE
[ gg PICA = Bx47; % SU2
[ 36 WTMK = B8;
37
P 38 P6L.7 = 1;
39
448 while{ g_start == 1 >{ »= PsegLEDé|6 _i
P 41 if ¢ 1PB.4 >{
42 g_start = 2;
43 H
P 44 >
45
[ 46 while { g_start == 2 » {
ad 47 if ¢ g_led s >= 68 >{ o= 4J4 =
< 48 g_start = @; A
e ‘rlz N P6L.7 = 8; =]
— [«

Stop the program.

% IDB50-TK : SAMPLE_K12.prj =101 x|
File Edit Yiew Option Run Event Browse Jump Window Help
e v [n = [erfon] 2 | 58 | BI|RS] Qa2 =65 =] 1¥]]5]
_oix i1 x
_
& seach. | |_» | Wach | uck. | Rehesh | Cose |
(. common.c 10| 14|lr= EU1:PB4/INTP1.GUESWZ :PA3/INIPA *=- =]
[ ortE s 5
[ iritialise 16 3 ;
inkermupt.c L 17 léu id main<?
main.c 19
[ 28 h_initiald{>; s% ACAJAVAAREACAY =~
I 21 EIC>; /% CPURHEDIRE] iliey *
22
23 vhile <13
24
25 g_start =
< 26 g_led_s
27 g_count =
28 ;
[ 29 PICA = BxA7; #% SU
38
ind 31 WIMK = 1;
32
i3 313 while( g_start == bH % BuAiS0&ESE
ind 34 PICB = Bx47; s SU2
35
[ 36 WIMK = 8;
37
[ 38 PEL.7 = 1;
37
40| while{ g_start == 1 >{ ~» PeegLEDé|6_i
> 41 if ¢ 'PA.4 X<{
42 g_start = 2;
43 >
[ 44| H
45
pe 46 vhile ¢ g_stapt == 2 £
[ 47 if ¢ g_led_s >= 68 >{ e SJS'LI
=3 48 g_start = @; 2|
ind 49 PeL.7 = 8; T
LIl -+
= »
|main. c#41 main |ooooodFC | [EREAK [Manual Break v

When the program stops, the status bar changes back to its original color.
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Exiting monitor-version integrated debugger (ID850-TK)

In the ID850-TK menu, select [File] -> [Exit].

i ID@50-TK : SAMPLE_KJZ.prj _[of x|
File Edit Yiew ©Option Run Event Browse Jump Window Help
Open... Chrl+0 " =| B i =
s 0| Q& B 4|m| EH 19|
Close: =10l x|
Bouribad. . | Quik.. | Fiofiosh |_Gose |
Load Module, . 1-TNTP1,iPSUZ:PA3/INTFE =/ =]
Upload...
Project 3 g
Ervvironment »
| initial{>; s GCAJAVSAGEACAY = =
g —EL O35 #x CPUEREBIRE] iliET »~
(Frﬂ GES
; g_start
L = g_led_s
2 Hew Folderi TKESOYSAMPLE_KIZISAMPLE._KIZ.6rj g_count
2 i ew Folder| TKESOYSAMPLE_KIZia,0ut T o I Su:
3a
e 31 WIMK = 1;
32
3 33 while( g_start == bH »% BUBIA0AEACE
ol 34 PICA = Bx47; #= U2
35
ol 36 WTHK = 8;
37
ol 38 P6L.7 = 1;
39
40| vhile{ g_start == 1 >{ % PeagLEDEé|6 i
> 41 if ¢ 'PA.4 >{
42 g_start = 2;
43 ¥
ol 44 >
45
il 46, while { g_start == 2 > {
e 47 if ¢ g_led_s »>= 68 >{ ed SJQ';I
e 48 g_start = B; Bl
e 49 P6L.7 = B3 =]
| - c +
KI| |
main.c#41 Imain |ooooosFc | BREAK |Manual Break v

The Exit confirmation dialog box is

displayed.

ID&50-TK

2)

Yes

This will end wour Debugger session,
Do wiol wank ko save the settings in the project file ?

Mo | Zancel |

x|

Press the button. The current environment is saved and then ID850-TK ends.

ID850-TK ends without preserving a present environment if are pushed.
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Closing PM plus

In the PM + menu, select [File] -> [Exit PM +].

PM plus - SAMPLE_K1Z.prw [ProjectWindow]

File Edit Find Layer Wiew Project

Build  Tool

Window Help

Chrl+-M
Chr-O

Mew
CIpEr, .

B B | G [id

[¢2+ ==z

dl

Insert file .,
Close

D ebug Buid

4| B

New Workspace. ..
Open Workspace. ..
Save Wiorkspace
Close Warkspace

Save Chrl+5

SEVE RS, ..

Change Source File Name. ..
Save Allsource Fles

Print Preview

Frimb. . Chrl+F

Recent e

C —

ol

. |
- Downlosd C:\NEWFOL~1%TESS50%SAMPLE~1%a.o0ut to the debugger.[EQ:

=10/ x|

-

A

Exit P+ and prompt to save the files

PM + ends.

[ O I R P2



CHAPTER 3 OTHER

This chapter describes how to create a new PM + workspace (project) required for debugging using the

monitor-version integrated debugger (ID850-TK), and how to use the PG-FPL.

Creating a new PM plus workspace (project)

Reqistering additional source files

How to use PG-FPL

-32 -
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Creating a new PM plus workspace (project)

Create a new workspace and project.
With PM +, a project that includes the basic items required for build can easily be created by inputting each of
various items step by step.

In the PM + menu, select [File] -> [New Workspace...].

55 PM plus - No Workspace [OutPut] 3 =181
Fle Edt Find Layer Wiew Project Buld Tool Window Help
Mew ChrkHi ,—;[ “« %+ - = |
. o 28] \ I=l=]ie
Insert = 5 i®ix (@ |
Close
EE— o]

Save Workspace:

Close Workspare

Save. {5
Save As...

Chenge Source File Hame...
Save Al Saures Fes

Print Preview
Print. .. Chrl+P

Recent File

Riecent Workspace

Exit PM+

Kal} H
Create anew warkspace [ LiRifwr

The dialog box for creating

new workspace is displayed.

<Description of items>

New WorkSpace - Step 1,/9 [Workspace Information] x|
Workspace File Name: *Wworkspace Fils Name :
-> Specify the name of the workspace file that | ’”2 ;"T"‘:"T“T‘”f”m“D”
manages the prpject filesf. . ) _ I~ Cieate Blank Workspace . SZIZZ HZ:fTimeDS[#]
.prw is automatically suffixed as the file oldery 4 Statp Flef]

Browse..
type. I M 5, Register Mode(#)

Project Group Mame :

A project file (.prj) of the same name is | £ Link Ditective File[#]
simultaneously created.

7. Setup Source Files

Series Name : Device Mame :
[/350 Seres =] [wPoroFarze || @ oelect bebugeer
Folder: —— 9. Confirmation
-> Specify the folder for saving the workspace Lﬂsml [#] V850 Seiiss Orly [3-6)
file by writing its absolute path.
This item can be selected from a reference
dialog box by pressing the Browse...
button. This will set up the basic infarmation about the warkspace and the project.

Project Group Name:
-> Specify this item if wishing to manage
multiple projects together in function units. ¢ Back Hews | [ Caneel | Help
If nothing is specified, this item is the same
as the workspace file name.

Series Name:
-> Specify the series name of the device to be
used.

Device Name:
-> Specify the name of the device to be used.

The concrete information set here is

described on the following pages.
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New WorkSpace - Step 1,/9 [Workspace Information] il
Input the workspace information settings “Workspaca File Name
|test >x1. Wortkspace [nformation

as follows. o
elect | oolz
; < Folder [™ Cieate Blank Workspace 3 Select Real-Time 0S7H]
Workspace File Name: |c-xms§nuesu Browse.. | 4. Startup Fle{#)
-> test Prokect Groug Nare 5 Register Mode(#)
E. Link Directive Fils[#]
5 I . . 7. Setup Source Files
FOlder. Series Name : Device Mame :
[vasn Series =] [wororaras =] | O oeiectDebuaser
>C:\\TK850\test — 9 Confmaion
(Press the Browse...| button.) (F1/850 Seties Only (36)
Project Group Name:
-> Don,t InpUt thlS item. This will zet up the basic infarmation about the warkspace and the project.

Series Name:
-> V850 Series

< Back <I Mext > I > Cancel Help

Device Name:
-> uPD70F3734

k / Press the button.

PMpius x|

& Q2011: CATKEA0 est

Thiz folder cannot be found. Do vou wizh o create ity

Press the button.

New WorkSpace - Step 29 [Select Tools] x|

Tool Set : 1. Workspace Information

ware Package 4.1 0[Edhd Save | Deletel 332 Select Tools

3. Select Real-Time O5[#)

Toal Versions : .
4. Startup File([#]

Teol | ersion 21| 5 Register Mode(#)
STESED w210 E. Link Directive File[#]
LDG V1.0 7. Setup Source Files
IDB506E Unused 8 et D hugges
\DEE0-TK Unused 4. Confirmation

| | [#]"%850 Series Only [3-6]
4| | *

< Dela\lSetling..I)

Pleaze select the Tools from MEC Electronics to be used

< Back I Mexst » I Cancel Help
Press the |Detail Setting..| button.
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Tool Yersion Detail Setting |

| casso | sTkeso | DG | ID8s0GE | IDEEOTK | |
d | JUnuzed [Unuzed 26
q

300 ) (720N |~ ¥

Please select each tool

version as follows.

CA850  :W3.00 ol ol
ID850-TK :V1.01 WA Series Software Package W4.10[English Version) ;I

850 Series Software Package 4.00[E nglizh “ersion]

I4]

( ak I ) Cancel | Help |

Press the @I button.

MNew WorkSpace - Step 2,9 [Select Tools] 1[

Tool Set: 1. Workspace Information

I[Changed]‘v’BSD Series Software Packag-j Save | Delete | »»2. Select Tools

3. Select Real-Time O5[#)

Tool Yersions :

4. Startup File[#]
e [[versian || & Register Modeit]
CAB50 w300
STEAS0 Y210 E. Link Directive File[#]
e V.01 7. Setup Source Files
IDE500E Uruzed
1D850-TE. W1.01 8. Select Debugger

4. Confirmation

[#]W850 Seriez Only [3-6]

Detal Setting...

Please select the Toals from MEC Electronics to be used.

<Bac:k{ i Mext » I , Cancel Help

TSe———

Press the button.

New WorkSpace - Step 3/9 [Select Real-Time 05] : il

Pleaze zelect the Real-Time OS[RTOS].

RTOS 1. Workzpace Infarmation
2. Select Tools

j »>3. Select Real-Time OS[#)
FBTOS Settings... | 4. Startup File(H]
5. Register Mode(#]

E. Link Directive File[#]

7. Setup Source Files

TK-850 does not use RTOS. 8. Select Debugger

4. Confirmation

[#]%/850 Series Only [3-5]

Pleaze select the Real-Time 05 (RTOS) from MEC Electronics to be used.
Only the installed RTOS from MEC Electranics can be selected.

< Back ‘ Mext » p Cancel Help

Press the button.
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New WorkSpace - Step [Startup File] x|

Flease specify the Startup File.

1. Waikspace Infarmation

% Copy and Use the S ample file 2 Select Tooks
T 3. Select Real-Time OS[#)
€ Uss the Evisting fie ﬂl >34, Startup File(#)
" Copy and Use the Existing file 5. Register Mode{#) Select the “Copy and Use the
Copy from : E. Link Directive Fils[#]
Browisz... | 7. Setup Source Files Sample file”.

= Do Mot specify now 8 Sl DethuEE

4. Confimation

) _ [#] %850 Series Ornly [3-6]
The Startup File Mame ta register

CHTRESMesthanE s Filz Name... |

The Startup File includes codes to be executed on Startup or Fleset.

The zample file initiahizes RAM and stack, then call: the "main' function. In caze of using the sample file,
pleaze customize it according az your target.

The specified Startup File is registered to the Praject Related Files.

<Back<| Mext > I > Cancel | Help
Press the button.

New WorkSpace - Step [Register Mode] Ll

Please select the Register Maode.

‘wWorkspace Information
Select Tools

Select Real-Time OS(#]
Startup File[3#]

E. Register Made(#]

Link Directive File[it]

" 22Register Mode

R

b3

.

" 2E-Register Mode

Setup Source Files

E
7
8. Select Debugger
g

Corfimation

Select the “ 32-Register Mode”.

[#) w850 Seriez Only [3-6]

According as the selected CABS0 Register Mode, the sample Startup File will be copied and used.
The Register Mode etz the number of registers internally uzed by the CABE0. Az a result of unused
registers, the registers nat used by the CABS0 can be used far the application pragram(in assembly
language] and the averhead required far saving and restoring registers can be reduced. Though the

¢ Back <I Mest > I > Cancel Help
Press the button.
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MNew WorkSpace - Step 679 [LinkDirective File] x|

Flease speci

+ ;Q_r_eate and Lize the Sample 1. Wworkspace Infarmation

2. Select Tools
. Select Feal-Time OS[#)

Ty 1
@ |se |ntemal memary anly " Usze External memory

w

4 Startup File[#]
= Use the Ezisting file Biowse... 5. Register Mode($)
™ Capy and Use the Existing file »»E. Link Directive Fils(H]
Cagy frorm : 7. Setup Source Files

oo || o sesapenage Select the “Create and Use the
Do Mot specify now 9. Confirmation L
N . [#)W850 Series Onlp (3-6] Sample file

The Link Directive File Mame ta register :

CATEBE0 st test. dir File Mame... |

The link. directive file describes infarmation about the allocation of program code and data.

In caze of using the sample file, Please customize it according az pour target. |f pou map the external
RO to the internal ROM area in ROM less mode, please select "use internal memony only™.

The specified link directive file iz registered to the Project Related Files.

< Back I Mext > I Cancel Help
Press the button.

New WorkSpace - Step 7/9 [Setup Source Files] il

Pleaze setup Source Files.
1. wiotkepace Information

Wi 2 Select Tools
3. Select Real-Time OS[#]

JCIEEN | R,
Fremove & | 5. Register Mode(#]

E. Link Directive Fils[#]
>37. Setup Source Files

Up | 8. Select Debugger
3. Confirmation
Down |
[#] %850 Series Ornly [3-6]

Source File Hame :

'T'ou can alzo add zource files by specifying the list file or the folder.
'Y'ou don't need to specify all the files here, and pou can setup source files using [Project]->[Project
Settings] later

< Back ( | Next > | ) Canecel Help

Press the button.
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New WorkSpace - Step 8/9 [Select Debugger] il

Pleaze select the Debugger.

1. wiotkepace Information
* Debugg

Select Tools

Select Real-Time OS[#]
Startup File[#]

Feqister Mode(#]

Link Directive File[#]

Setup Source Files

File name :

C:“Program Files\MEC Electranics Tools4DE50-TEAY .01 4bin%id3

Select the “ID850-TK V1.01"

oM s W R

DOption - >»8. Select Debugger

3. Confirmation

[H] YB50 Series Oy (3-6)

''ou can change the selected Debugger uzing [Tool] -» [Select Debugger].

< Back d Next > I, Cancel Help

\/
Press the button.

New WorkSpace - Step 9/9 [Confirmation] 1 il

Create the workspace and the project as follows,

1. wiotkepace Information
wiorkspace File Mame : = 2 Select Tools
test. prw
Folder : 3. Select Real-Time OS[#)
C:ATKBE0est :
Froject Group Name : 4 S AEL
test 5. Register Mode(#]
Reisslio: - N . Link Directive File(#]
Device Name : 7. Setup Source Files
UPD7OF3734
Tool Set Name : 8. Select Debugger
- velséﬁ};a:nged]\u’%ﬂ Series Software Package 4.10[English +53, Corfimation
e {#) V850 Series Orly [3-6)
LDG VA0
1D850-TK.%1.01 _
Fieal-Time 0% :
Mot uzed
Startup File :
CATKEEM esthortE 2
Fegister Mode :
32-Register Mode - o o g
< [ LH Check the project information

setting contents.




i PM plus - test.pre [OutPut]
File Edit Find Layer View Project Build Tool Window Help
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=18l

|2 -DEd @R 4 =0 @

Hl«=»+ -|[==R

J I test - test

|| Debug Buid

| &

A%t A|ENE|

=101

= ProjectWindo w

Files

35 test : 1 Project(s]
- test

i Saurce Files
-7 Include Files
+]- [ Project Related Files
w23 Other Files

- [ECF] ﬂ‘

registered.

The “test” project has been

=101

Make file created successfully,

This completes workspace and project creation.

O O 0

Additional source files can be registered at any time thereafter.

I::> For details, refer to “Reqistering additional source files”.

Next, setup the security ID

In the PM +, [Tool] — [Compiler common Options...] is selected.

ﬁﬂPM plus - test.prw [OutPut]

J%-DD”E|§&|% S
jIDebu
=101 x|

J [test - test

= ProjectWindow
Fies | Memo |

test : 1 Project(s]
=@ test
i -[] Source Files
-[Z] Include Files
-[Z7 Project Related Files
(L] Otther Files

Compiler Options...

Assembler Options...

Linker Cptions. ..

ROM Processor Options. ..

Hexa Converter Options. ..

Static performance analyzer Options. ..
Starkup STKES0

Startup LDG

=& xl;

[¢»+ -[=@

e+ X |8 |

dumpasao.. .

Debugger Settings...

Register Ex-toal. ..
Start up Ex-tao|

File Compare. ..
Device File Installer

PM+ Settings...
Fortk...
Customize. .,

Record the Key Operations
Elay Back

Save the Key Operations, ..
Load the Macra File. .,

Flay Back the Macra File. ..

Register the Macro Files. ..
Flay Back the Register Macro

=101 ]

-

X4

Set compiler common options.

[ I N RN Y
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Compiler Common Options ll

Fie | Statup | Link Directive | ROM | Flas

Intermediate Output Directon:

| Browse... |

Final Dutput Directary:

I Browss... |

Enar File:

| Browse... |

Thiz edit box can be specified a directary which object files, assembler source files,
assemble list files, frequency information files and extenal variable file are output.
Azeembler source files, assemble list files and frequency information files are output
there when directary name o file name is specified by the option

External variable file is autput there when file name with path is specified by the
option.

Compiler Common

Options setting is open.

oK I Cancel | Spply Help

Click the “Device” tab.

Compiler Common Options ll

Fie | Startup | Link Directive | ROM | Flash  Device

[~ 256 Byte Mode

BFC Register: I

EcLnty 10
|DxFFFFFFFFFFFFFFFFFFFF

The actualities of
"FFFFFFFFFFFFFFFFFFFE"(20 of F)

are taken if there is no problem in the
This edit box can be specified a security [0 bg hexadecimal.

‘when it is specified, +4sid option of the linker iz set. Value Of ID in security.

- J

( oK I) Cancel | Apply Help |

Press the @I button.

Security ID settings are complete.



Registering additional source files

The method for registering additional source files to a project is described below.

The following example shows the additional registration of source files “b.c” and “c.c” with source file “a.c” already
registered.

Place the cursor on the source file in the Project window of PM +, and select [Add Source Files...] displayed in the

right-click menu.

L% PM plus - test.prw [ProjectWindow] =
File Edit Find Layer ‘iew Project Buld Tool ‘Window Help

| - DSH|SR| S 2| | Hes+ -[B=El? |

J Itest-test leebug Build j| PR 3 3PS | B |

= ProjectWindow -10] x| =] 9]
Fies | Memo | =l
E|--- test - 1 Project(s)
Eﬁ test
=0
-E Incl.udE Compiler Options. ..
+ (0 Project Assembler Options. ..
‘.7 Other Fr
Add the source File ko the project l_ ,L_ ,X_ ,\"_

Add Source Files - test 2 2=
Look in: |ﬁ test j - £ EE-
ac
B
|:.E
crtE.s
Select source files “b.c” and “c.c” and
then press the button.
File hame: I"b_c" gl < Open I >
Files of type: ISource Files[" ;% 0257 5] j Cancel |
Help |
Add Files from Folder... |
A

Multiple source files can be selected by clicking the desired source files while pressing key.
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S.E'PM plus - test.prw [ProjectWindow] =1
File Edit Find Layer Wiew Project Buld Tool Window Help
ERIEENE LY e » + -=mle |
J Itesl-test leebugEuiId j| & .'.1. :“E*. 'ﬁ' .2.‘. | I?hﬂ m |
= ProjectWindow =] 3] = =10l x|
Fies | hsemo | - [EOF] =
test - 1 Projectis]
= test
el lclude Eile
-] Project Related Files
“-(_7] Other Files
Source files “b.c” and “c.c”
are additionally registered
to the project.
1] H
For Help, press F1 l_l_ ,L_ IX_IV_
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How to use PG-FPL

It explains the method of deleting the flash memory with built-in V850ES/KJ2 by using PG-FPL.

When security ID etc. are forgotten and ID850-TK cannot be connected, PG-FPL is used.

PG-FPL cannot be installed from an integrated installer. Please execute and install

¥FPL¥FPL_V122¥Setup.exe
from the Explorer etc. Please refer to "PG-FPL user's manual” for details of the installation method.

However, it is not necessary to install hardware (driver). As for TK-850/KJ2, the hardware of PG-FPL is built in.

The switch of TK-850/KJ2 is set as follows, and it connects it with the PC.

SW3

Bit 1 ON
Bit 2 OFF
Bit 3 ON
Bit 4 ON

Please select — [Programs] — [NEC Tools32] — [PG-FPL] of the Windows start menu.

The initial screen of PG-FPL

File_ Device Yiew Help
| —

=101 x|

Ready

Device—
Mame :

Firrmn Yersion ;
ExtCode :
Wendor :

Parameter file
MHarme :
Format :
Wersian :
Processar Ver,

Laad file
MHame
Date
Chiksum :
Area:

Connection ta device
Part :
Speed
Range
Freq. :
Fultiply -

o

[ m[

Push the 'Setup) button.
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zl
Standard | Advancel
/ ~\
Parameter file | PAM Fiz Read| | )
—Host connection——————— [~ Supply oscillator

Part I vI Frequency I MHz
Speed I vI Multiply rate I

— Operation Mode

" Chip Start I - l
" Black End I A l

 Area [~ Show Addres

[ Target Reset Message

ok | Cancel

Push the TPRM File Read] button.

open (x|
Laok in: |3 PRM70F3734_/100 o e®merE

8] 7OF3726.prm
FOF3728.prm
F0F3729.prm
FOF3731.prm
FOF3732.prm
FOF3733.prm

File name: I?DF3?34.prm Open

Files of type:  [PRM Files(PRM) | Cancel |
VA

/PRM/PRM70F3734_V100/70F3734.prm of attachment CD is selected.

x

Standard | Advance |

Parameter file |?DF3?34.prm PR Filz Read
W

Part IEDM3 vI Frequency |5.00 MHz \\>

Speed [3memn = ultply et [4.00 P
\ 1

e

— Operation Mode

' Chip Start I oog - l
" Block EndI‘IZ? 'l

) Area [~ Show Addres

C (] D Cancel |

"Port" selects the COM port number where TK-850 is allocated.

[” Target Reset Message

*Only the COM port number that the personal computer has is displayed in this pull-
down menu.
Please select as follows.
[Speed] 38400, [Frequencyl 5.00. [Multiply rate] 4.00

Push the .
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ol x|

2

»» FlashOpenning.... - Device
Flash DpeﬁDK 2 B Hame :

2 COMMAMND; Device Setup
PR File Read OK. Firmn Version :
ExtCode :
Wendor

——— Parameter fila—
Mame : 7OF3734
Farmat : 0413
Wersion @ W1.00
Processor Ver, 0200

Load file -
Mame
Diate :
Chiksum :
Area

Connection to device -
Paort:  COM3
Speed 38400
Fahge Chip
Freg.: 5.00
Multiply - 4.00

i o

Ready [ hom [

"Erase" The deletion of the flash memory begins when the button is pushed.

_Ioix

File Device Wiew Help

Yk 7 8 ¥

sCOMMAND: Erase :I Device
ecking.. Mame : D OF ety

F

lazh Erazing...
chip eraze finish.

Firm ersion:  2.00
ExtCode : 7FOTh

Wendor 10h
— Parameter fila
Mame : VOF3734
Farmat : 0413
Wersion : W1.00
Proceszar Ver. 0200
Load file -
Mamne
Date :
Chiksum :
Area
Connection to device -
Part:  COM3
Speed 22400
Rahge Chip
Freq.: 500

bultiply - 4.00

L Hal

Ready [ [

If "chip erase finish" is displayed, the deletion of the flash memory is completed.

Please end PG-FPL.

It returns based on the set switch and completion.

SW3

Bit 1 ON
Bit 2 ON
Bit 3 ON
Bit 4 OFF




